Closed Bug 1734870 Opened 4 months ago Closed 4 months ago

Dragging a link to tabbar will not open the link, but rather the associated image.

Categories

(Core :: DOM: Copy & Paste and Drag & Drop, defect)

Firefox 94
Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
firefox-esr78 --- wontfix
firefox-esr91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- wontfix
firefox95 --- verified

People

(Reporter: alice0775, Assigned: evilpie)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community, parity-chrome)

Attachments

(1 file)

Chrome94 works as expected, but Firefox94b2,95.0a1 does not.

Steps to reproduce:

  1. Open https://jp.mercari.com/
  2. Drag a product image to tabbar

Actual Results:
The associated image will open.

Expected Results:
The link href (detailed page) should open.

Looks like the image is inside a shadow-root, but the link is outside. We probably don't cross shadow DOM boundaries when considering if some image is a link.

For your reference.
In Firefox 93, right-clicking on a product image will only bring up the context menu for image.
In Firefox 94, the context menu has been fixed by Bug 1730625 and pops up including the context menu for links as expected.
However, for the D&D, it is still broken not only in Firefox93, but also in 94 and 95.0a1.

See Also: → 1730625
Assignee: nobody → evilpies
Status: NEW → ASSIGNED
Attachment #9245101 - Attachment description: Draft: Bug 1734870 - Look for draggable links across shadow roots. r?emilio → Bug 1734870 - Look for draggable links across shadow roots. r?emilio
Blocks: 1735176
Pushed by evilpies@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1fc133268d32
Look for draggable links across shadow roots. r=emilio
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

The patch landed in nightly and beta is affected.
:evilpie, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(evilpies)

This is a longstanding issue, we don't need to uplift.

Flags: needinfo?(evilpies)
Flags: qe-verify+

Reproduced with Fx 95.0a1 (2021-10-05) on Windows 10.
Verified fixed with Fx 96.0a1 (2021-11-02) and Fx 95.0b1 on Windows 10, macOS 11 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.