Closed Bug 1734977 Opened 3 months ago Closed 3 months ago

(Debian) 91.x build fails on i386

Categories

(Thunderbird :: Build Config, defect)

Thunderbird 91
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1729459

People

(Reporter: c.schoenert, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

While preparing the packaging of the next ESR Version 91.x for Debian I noticed that starting with version 91.0.2 the build of Thunderbird packages on architecture i386 is failing.

https://buildd.debian.org/status/logs.php?pkg=thunderbird&arch=i386

Actual results:

The is visible as follows:

make[5]: Leaving directory '/<<PKGBUILDDIR>>/obj-thunderbird/js/src/wasm'
make[5]: Entering directory '/<<PKGBUILDDIR>>/obj-thunderbird/modules/fdlibm/src'
mkdir -p '.deps/'
modules/fdlibm/src/e_acos.o
/usr/bin/clang++ -std=gnu++17 -o e_acos.o -c -I/<<PKGBUILDDIR>>/obj-thunderbird/dist/stl_wrappers -I/<<PKGBUILDDIR>>/obj-thunderbird/dist/system_wrappers -include /<<PKGBUILDDIR>>/config/gcc_hidden.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -fstack-clash-protection -DNDEBUG=1 -DTRIMMED=1 -DEXPORT_JS_API -DMOZ_HAS_MOZGLUE -I/<<PKGBUILDDIR>>/modules/fdlibm/src -I/<<PKGBUILDDIR>>/obj-thunderbird/modules/fdlibm/src -I/<<PKGBUILDDIR>>/obj-thunderbird/dist/include -I/usr/include/nspr -I/usr/include/nss -I/usr/include/nspr -I/<<PKGBUILDDIR>>/obj-thunderbird/dist/include/nss -DMOZILLA_CLIENT -include /<<PKGBUILDDIR>>/obj-thunderbird/mozilla-config.h -Qunused-arguments -Wdate-time -D_FORTIFY_SOURCE=2 -Qunused-arguments -Wall -Wbitfield-enum-conversion -Wdeprecated-this-capture -Wempty-body -Wformat-type-confusion -Wignored-qualifiers -Wpointer-arith -Wshadow-field-in-constructor-modified -Wshadow-uncaptured-local -Wsign-compare -Wtype-limits -Wno-error=tautological-type-limit-compare -Wunreachable-code -Wunreachable-code-return -Wno-invalid-offsetof -Wclass-varargs -Wempty-init-stmt -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wno-range-loop-analysis -Wc++2a-compat -Wcomma -Wenum-compare-conditional -Wimplicit-fallthrough -Wstring-conversion -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=backend-plugin -Wno-error=return-std-move -Wno-error=atomic-alignment -Wno-error=deprecated-copy -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-psabi -Wno-unknown-warning-option -fno-sized-deallocation -fno-aligned-new -O2 -ffile-prefix-map=/<<PKGBUILDDIR>>=. -fstack-protector-strong -Wformat -Werror=format-security -fno-exceptions -fno-strict-aliasing -fPIC -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -O2 -fomit-frame-pointer -funwind-tables -Wno-parentheses -Wno-sign-compare -Wno-dangling-else -fexperimental-new-pass-manager -MD -MP -MF .deps/e_acos.o.pp /<<PKGBUILDDIR>>/modules/fdlibm/src/e_acos.cpp
modules/fdlibm/src/e_acosh.o
In file included from /<<PKGBUILDDIR>>/modules/fdlibm/src/e_acos.cpp:44:
/<<PKGBUILDDIR>>/modules/fdlibm/src/math_private.h:34:21: error: typedef redefinition with different types ('__double_t' (aka 'double') vs 'long double')
typedef __double_t double_t;
^
/usr/include/math.h:156:21: note: previous definition is here
typedef long double double_t;
^
1 error generated.
make[5]: *** [/<<PKGBUILDDIR>>/config/rules.mk:676: e_acos.o] Error 1
make[5]: Leaving directory '/<<PKGBUILDDIR>>/obj-thunderbird/modules/fdlibm/src'
make[4]: *** [/<<PKGBUILDDIR>>/config/recurse.mk:72: modules/fdlibm/src/target-objects] Error 2
make[4]: *** Waiting for unfinished jobs....

I've looked into our patches we apply but there is no patch that is touching the source file in question.
https://salsa.debian.org/mozilla-team/thunderbird/-/tree/debian/experimental/debian/patches

I can reproduce this issue also again locally for version 91.2.0 which get not uploaded yet.

Summary: (Debian) build fails on i386 → (Debian) 91.x build fails on i386
Status: UNCONFIRMED → NEW
Ever confirmed: true

Hi Cartsen, thanks for reporting this. It looks like the Firefox-esr-i386 build for 91.2.0 failed the same way: https://buildd.debian.org/status/fetch.php?pkg=firefox-esr&arch=i386&ver=91.2.0esr-1&stamp=1633486896&raw=0

Flags: needinfo?(mh+mozilla)
Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(mh+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 1729459
You need to log in before you can comment on or make changes to this bug.