Closed Bug 1735160 Opened 10 months ago Closed 10 months ago

TB 91.x does not send QUIT to SMTP server before disconnect

Categories

(MailNews Core :: Networking: SMTP, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird_esr91 fixed, thunderbird94 fixed)

RESOLVED FIXED
95 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird_esr91 --- fixed
thunderbird94 --- fixed

People

(Reporter: wbreyha, Assigned: rnons)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:92.0) Gecko/20100101 Firefox/92.0

Steps to reproduce:

This issue came up since we check for clients not sending QUIT at the end of mail submissions. Up to TB78 this was not an issue and we actively logged that QUIT was correctly sent.

Since the roleout of TB91 we see that QUIT is no longer sent before TB disconnects. This is at least true for Windows builds and the Fedora 34 build.

I checked this with a debugging session on the server side with exim 4.95 as a server.

Actual results:

Note that this was a implicit SSL connection on port 465:
15:55:41 31778 SMTP>> 250-mail.xxxxxx.xx Hello xxxx [2001:xxxx]
15:55:41 31778 250-SIZE 104857600
15:55:41 31778 250-8BITMIME
15:55:41 31778 250-DSN
15:55:41 31778 250-VRFY
15:55:41 31778 250-EXPN
15:55:41 31778 250-PIPELINING
15:55:41 31778 250-AUTH SCRAM-SHA-1 SCRAM-SHA-256 PLAIN LOGIN
15:55:41 31778 250-CHUNKING
15:55:41 31778 250-SMTPUTF8
15:55:41 31778 250 HELP
15:55:41 31778 SMTP<< AUTH PLAIN ....
15:55:41 31778 SMTP>> 235 Authentication succeeded
15:55:41 31778 SMTP<< MAIL FROM:<wxxxxxx@xxxxx> BODY=8BITMIME SIZE=512
15:55:41 31778 SMTP>> 250 2.1.0 Ok
15:55:41 31778 SMTP<< RCPT TO:<echo@univie.ac.at>
15:55:41 31778 SMTP>> 250 2.1.5 Ok
15:55:41 31778 SMTP<< DATA
15:55:41 31778 SMTP>> 354 Enter message, ending with "." on a line by itself
.....
15:55:41 31778 SMTP>> 250 2.0.0 OK id=1mZvmH-0008GY-TU
15:55:42 31778 SSL3 alert read:warning:close notify
15:55:42 31778 Got SSL_ERROR_ZERO_RETURN
15:55:42 31778 SSL3 alert write:warning:close notify
15:55:42 31778 using ACL "acl_check_notquit"

Expected results:

The same as TB used up to 78. Send a quit before disconnecting as required by RFC5321:3.8

Component: Untriaged → Networking: SMTP
OS: Unspecified → Linux
Product: Thunderbird → MailNews Core
Hardware: Unspecified → x86_64
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Confirmed with TB91.2 and pref: mailnews.smtp.jsmodule TRUE

The Quit command is sent if mailnews.smtp.jsmodule is set to FALSE.

OS: Linux → All
Regressed by: 1679730
Hardware: x86_64 → All
Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Target Milestone: --- → 95 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/8ce7565010e4
Send QUIT before closing SMTP connection. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED

Comment on attachment 9245363 [details]
Bug 1735160 - Send QUIT before closing SMTP connection. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1661694
User impact if declined: QUIT command is not sent to SMTP server after sending message, but no impact to end users
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9245363 - Flags: approval-comm-esr91?
Attachment #9245363 - Flags: approval-comm-beta?

Comment on attachment 9245363 [details]
Bug 1735160 - Send QUIT before closing SMTP connection. r=mkmelin

[Triage Comment]
Approved for beta.

Attachment #9245363 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9245363 [details]
Bug 1735160 - Send QUIT before closing SMTP connection. r=mkmelin

[Triage Comment]
Approved for esr91

Attachment #9245363 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.