All users were logged out of Bugzilla on October 13th, 2018

[PP][BLOCKER][dogfood] Linux crashes at Startup using IMAP

VERIFIED FIXED

Status

P3
blocker
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: nbaca, Assigned: dougt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Build 1999102709M11: Linux/Redhat 6.0

Overview: Start Mail using an IMAP account. Expand the folders, select the Inbox
and it tries to display the folders and messages but then it crashes.

Step to reproduce:
1. Start Mail
2. Select an IMAP profile
3. Expand the IMAP account to see all the folders

Actual Results: Sometimes by selecting the Inbox it crashes right away. Other
times it gets as far as showing the Password prompt but quickly crashes.

Expected Results: Selecting the Inbox should automatically prompt for a
password so that email messages would display, without a crash.

Additional Information:
- Starting Mail with a POP account works fine, no crash.
- Will check Windows and Mac soon.

Updated

19 years ago
Severity: normal → blocker
Summary: Linux crashes at Startup using IMAP → [BLOCKER] Linux crashes at Startup using IMAP

Updated

19 years ago
Summary: [BLOCKER] Linux crashes at Startup using IMAP → [BLOCKER][dogfood] Linux crashes at Startup using IMAP

Comment 1

19 years ago
I see this on my linux box as well with today's build.  nuke .mozilla directory,
create new profile, set up IMAP mail, and it crashes when you click on the inbox
folder.

This is dogfood and blocker, and the tree will remain closed until it is fixed.
(Reporter)

Comment 2

19 years ago
Build 1999102709M11: Win32/NT4
Launches Mail with an IMAP account as expected, no crash.

Comment 3

19 years ago
dougt made large changes to proxy handling last night that might be the root
cause.  he is looking at this and will check in in a half hour or so.

Updated

19 years ago
Summary: [BLOCKER][dogfood] Linux crashes at Startup using IMAP → [PP][BLOCKER][dogfood] Linux crashes at Startup using IMAP

Comment 4

19 years ago
Oh man...I started seeing this last night around 11:30 and figured I caught
someone's code in mid checkin so I started a clobber build.

I was actually crashing way out in some gtk code. It didn't make much sense
at the time which is why I just assumed something in my tree was out of date.

I'll look at it again. I'm pretty sure the problem isn't with any imap code.
Jonathan mentioned that dougt is looking at this too. I'll add him to the cc
list.

Comment 5

19 years ago
Here's the stack trace I saw last night that I thought was just my tree but it
turns out is effecting everyone:



(gdb) where
#0  0x405259b2 in event_processor_callback (data=0x8658638, source=24,
condition=GDK_INPUT_READ) at nsAppShell.cpp:221
#1  0x4052537f in our_gdk_io_invoke (source=0x8661100, condition=G_IO_IN,
data=0x8656970) at nsAppShell.cpp:49
#2  0x406c03ca in g_io_unix_dispatch ()
#3  0x406c1a86 in g_main_dispatch ()
#4  0x406c2041 in g_main_iterate ()
#5  0x406c21e1 in g_main_run ()
#6  0x405eb7a9 in ?? () from /usr/lib/libgtk-1.2.so.0
#7  0x40525ebf in nsAppShell::Run (this=0x809f5b8) at nsAppShell.cpp:388
#8  0x40399cd1 in ?? () from /builds/mscott/mozilla/dist/bin/./libnsappshell.so
#9  0x804b777 in main1 (argc=2, argv=0xbffff9c4) at nsAppRunner.cpp:604
#10 0x804b9f9 in main (argc=2, argv=0xbffff9c4) at nsAppRunner.cpp:694
#11 0x40294cb3 in ?? () from /lib/libc.so.6
(Assignee)

Comment 6

19 years ago
Did you enter a password in the Account Setup?  Is a password dialog being
displayed when you click on the In-Box?

Comment 7

19 years ago
in my case, I entered a password in the account setup but didn't click remember
password.  Then after trying to open the Inbox (I think it was on a doubleclick)
it crashed, no dialogs, no nothing.

Comment 8

19 years ago
I'm actually configured for remember password so it shouldn't be trying to
bring  up the password dialog when we crash.

Comment 9

19 years ago
mscott is going to check in a temporary hack to workaround this issue.  we still
need to figure out the root cause and solve this.  If the problem isn't fixed by
Friday, we're going to keep the tree closed over the weekend.

Comment 10

19 years ago
I respun linux with mscott's fix and did not see this problem.  sent the builds
to QA for additional testing.
(Assignee)

Updated

19 years ago
Assignee: mscott → dougt
(Assignee)

Comment 11

19 years ago
I have the real fix in hand.  Sending to mscott and pav for a look.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 12

19 years ago
Putting on PDT+ radar.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

19 years ago
Fix now checked in.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 14

19 years ago
Build 1999102808M11: Linux/Redhat 6.0
Verified Fixed.

With an IMAP account I was able to start, open a folder, read a message, send a
message, receive a message and exit without a crash. Great!

Comment 15

19 years ago
*** Bug 17443 has been marked as a duplicate of this bug. ***
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.