Closed Bug 1735335 Opened 3 months ago Closed 3 months ago

Fix and run browser_storage_cache_navigation.js test only with server side targets

Categories

(DevTools :: Storage Inspector, enhancement)

enhancement

Tracking

(firefox95 fixed)

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: ochameau, Assigned: ochameau)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Whiteboard: dt-perf-stability-mvp)

Attachments

(1 file)

In order to remove client side target switching (bug 1713093 ), we have to fix devtools/client/storage/test/browser_storage_cache_navigation.js to run fine only with server side targets.

For now, it runs the test a first time with client side targets to workaround actual failure in storage panel. Cache and indexed-db aren't correctly updated when a new database is created after the panel is opened.

We could fix this and have the test to only run with server side targets.

Note that bug 1712757 already covers that, but here the test is only about Cache, so I'll only fix caches view.

The issue was that when the UI calls getStoreObjects, we weren't fetching new cache databases.
The API of getStoreObjects is so convoluted and seems to be quite limited that I haven't
found any way to notify about brand new databases.
So, instead I emit RDP event to notify about the new databases.

It fixes a couple of things for Caches:

  • the refresh button now works (before it wasn't detecting new dabases)
  • when selecting a host, it will also update things correctly
  • ultimately, it helps cleaning up browser_storage_cache_navigation.js
Pushed by apoirot@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f7354d5f93c1
[devtools] Fetch new caches when selecting cache in the tree. r=nchevobbe
Regressions: 1735651
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.