Closed Bug 173534 Opened 17 years ago Closed 15 years ago

table rendered with incorrect width if text font is Verdana

Categories

(Core :: Layout: Tables, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 95067
Future

People

(Reporter: homer, Unassigned)

References

()

Details

(Keywords: qawanted)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1) Gecko/20020826

On the page at http://rjmaguire.com/test/prog-verd.html you can see the tables
in the center are incorrectly rendered. The middles are stretched out too far
(i.e. the right edge should be flush with the top and bottom graphic).

I've seen this in Mozilla 1.1 for OS X as well as for Windows XP and 98.

There's an identical version of the page at http://rjmaguire.com/test/prog.html
that uses Tahoma instead of Verdana, and the tables render correctly.  All I did
was copy the document and point to an alternate style sheet.  This also happens
if I override stylesheets in the preferences and switch back and forth between
Tahoma and Verdana.

On either page, neither IE 5.2 nor Opera 6.0b1 for OS X have any difficulty
rendering the tables correctly.  OmniWeb 4 and iCab 2.8.2 exhibit the same
behaviour as Mozilla, however.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Happens on Linux too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirming on WIN2K with latest trunk build: 2002-10-23-08-trunk.
Priority: -- → P3
Target Milestone: --- → Future
mass reassign to default owner
Assignee: karnaze → table
QA Contact: amar → madhur
Target Milestone: Future → ---
Target Milestone: --- → Future
a reduced testcase would be nice
Keywords: qawanted
I think this bug is invalid.

I started work on a testcase but found that the reason the edge of the tables
are not flush is that the line of dashes towards the bottom force the width to
be increased. I guess Verdana has a wider dash than some other fonts. It looks
to me like mozilla is behaving as it should.

The hyphens wrap in IE. They don't in Moz.

*** This bug has been marked as a duplicate of 95067 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.