Closed Bug 1735562 Opened 3 months ago Closed 3 months ago

Remove Nightly only code for multiple cc number capture and autofill behavior

Categories

(Toolkit :: Form Autofill, task, P3)

task

Tracking

()

RESOLVED FIXED
95 Branch
Tracking Status
firefox95 --- fixed

People

(Reporter: tgiles, Assigned: tgiles)

References

Details

Attachments

(1 file)

As part of Bug 1688607, we added some Nightly only gates for this new behavior since this behavior needs some extra time to bake and ensure there are no large regressions from promoting this feature.

Severity: -- → N/A
Priority: -- → P3

Hmm, we have two regressions from these Nightly gates (Bug 1736011 and Bug 1736048). I'm not sure if the correct path is to add more RELEASE_OR_BETA checks in the test code, creating unnecessary branching, or to remove the Nightly gates in the codebase which would give us less time to test the feature.

I'm personally leaning for removing the Nightly gates, since credit card autofill isn't enabled in Germany yet, and dealing with any follow-up regressions. I think this would reduce the complexity of branching in our test cases...since there's going to be more regressions filed once the previous two are fixed. The following tests would also need NIGHTLY_BUILD and RELEASE_OR_BETA statements added to them:

  • test_autofillFormFields
  • test_collectFormFields
  • test_onFormSubmitted
  • test_markAsAutofillField

I guess an alternative is, instead of using the NIGHTLY_BUILD to hold the feature back, to use a pref instead. That way we can set the pref in test and not have as many branching conditions based on environment...but I think I'm still in favor of just letting the feature ride the trains.

Assignee: nobody → tgiles
Status: NEW → ASSIGNED
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/15d030894e93
Remove Nightly only gates for multiple cc-number field capture and autofill. r=sgalich
Blocks: 1736048
Blocks: 1736011
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
You need to log in before you can comment on or make changes to this bug.