Satchel should replace password manager

VERIFIED FIXED in mozilla1.5

Status

()

--
enhancement
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: bryner)

Tracking

unspecified
mozilla1.5
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
 
(Reporter)

Updated

16 years ago
Target Milestone: --- → Phoenix0.4
(Reporter)

Updated

16 years ago
Target Milestone: Phoenix0.4 → Phoenix0.5

Comment 1

16 years ago
*** Bug 176314 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
*** Bug 177156 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
*** Bug 176155 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 180509 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

16 years ago
Target Milestone: Phoenix0.5 → Phoenix0.6

Updated

16 years ago
Blocks: 180540

Comment 5

16 years ago
*** Bug 181390 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Severity: normal → enhancement

Comment 6

16 years ago
*** Bug 182848 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
*** Bug 183099 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
I guess this is probably the place to put this:
In Phoenix 0.5 (and possibly earlier versions), in the JS Console, you can still
do Tools -> Password manager.  

Of course there is also a menu option for the JS Console on the JS Console.  

Comment 9

16 years ago
*** Bug 183945 has been marked as a duplicate of this bug. ***
One of the great things about password manager is that for situations in which
you only have one username/pass for a given site (i.e. most cases) the info is
just prefilled automatically when the page loads, meaning you don't need to
click-down-arrow-enter then grab the mouse again to click "Login". Logging in
becomes a single mouse action rather than a series of actions. 

That said, my belief is that the autocomplete system used by satchel is the best
way to show and select between multiple logins for a given page (rather than the
current dialog). 

Comment 11

16 years ago
I concur with Ben, if there are several possibilities, I think that the focus
should be on the identity form, the autocomplete widget open. Selecting an
identity should prefill the password on the fly.

However, there would be a benefit only in the edge case of two or more identities
-> untargetting
Target Milestone: Phoenix0.6 → ---
(Reporter)

Comment 12

15 years ago
-> bryner
Assignee: hewitt → bryner
Target Milestone: --- → Firebird0.8

Comment 13

15 years ago
Taking QA. Sorry for the bugspam
QA Contact: asa → davidpjames

Comment 14

15 years ago
We already have the new password manager. With one identity, it prefills forms;
with two or more, it uses autocomplete.
-> fixed? Or does this bug ask for something else?

Comment 15

15 years ago
Adding [pwd-mngr] to summary of Password Manager bugs to facilitate querying.
Sorry for the bugspam.
Summary: Satchel should replace password manager → [pwd-mngr] Satchel should replace password manager

Updated

15 years ago
Component: Autocomplete → Password Manager

Comment 16

15 years ago
Is there a spec for this somewhere, that shows why all of these myriad bugs have
been duped to this one, which has a blank description, or is this simply an idea
in some developers head, with no timeframe for implementation?

Updated

15 years ago
Flags: blocking0.8?
(Assignee)

Comment 17

15 years ago
I'm not sure what Blake meant by this either, but we've replaced wallet with a
new satchel-based password manager, so I'd consider this done.  Please file
separate bugs for any remaining issues.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 18

15 years ago
That was done before 0.7 already -> setting target milestone to that.
Flags: blocking0.8?
Summary: [pwd-mngr] Satchel should replace password manager → Satchel should replace password manager
Target Milestone: Firebird0.8 → Firebird0.7

Comment 19

15 years ago
Target Milestone and Priority should be changed by the bug owner only.

Comment 20

15 years ago
Well the fact is that satchel *DID* replace password manager as of FB0.7, so
it's no longer a "target" but a "fait accompli".

Verified fixed.
Status: RESOLVED → VERIFIED

Comment 21

15 years ago
Sorry, this _may_ be unrelated: The case where the user might not remember the
first letter of the UN is *not discoverable*. I didn't know about
"down-arrow-to-reveal-all-UN/PW's" until I read this bug (no "normal" user will
find/read this bug). 

It may be better to bring up a dialog whenever a site is visited that requires
UN/PW _and_ FB has _several_ UN/PW's for that site.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.