Closed Bug 1735661 Opened 10 months ago Closed 7 months ago

Consistent crashes @ AsyncShutdownTimeout | profile-change-teardown | Extension shutdown: bdThunderbird78@bitdefender.com - "Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources."

Categories

(Thunderbird :: General, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91 affected)

RESOLVED DUPLICATE of bug 1732515
Tracking Status
thunderbird_esr91 --- affected

People

(Reporter: bobnancyweber, Unassigned)

References

(Blocks 1 open bug, )

Details

Crash Data

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.81 Safari/537.36

Steps to reproduce:

Ever since upgrading to version 91.2.0 (64-bit) two weeks ago, Thunderbird consistently crashes on shut down. It has never once shut down properly. I am using Windows 10 Pro, Version 21H1, OS buid 19043.1237, Windows Feature Experience Pack 120.2212.3530.0 PLEASE FIX THIS VERY FRUSTRATING PROBLEM.

Actual results:

Ever since upgrading to version 91.2.0 (64-bit) two weeks ago, Thunderbird consistently crashes on shut down. It has never once shut down properly. I am using Windows 10 Pro, Version 21H1, OS buid 19043.1237, Windows Feature Experience Pack 120.2212.3530.0 PLEASE FIX THIS VERY FRUSTRATING PROBLEM.

Expected results:

Normal, problem-free shut down.

Please see https://support.mozilla.org/en-US/kb/mozilla-crash-reporter-tb and post your crash IDs here.

Flags: needinfo?(bobnancyweber)

The bug id is 1735661. Is that what you need to know?

Flags: needinfo?(bobnancyweber)
Flags: needinfo?(bobnancyweber)

I have read the Mozilla Crash Reporter TB at https://support.mozilla.org/en-US/kb/mozilla-crash-reporter-tb, but WHAT MORE IS IT YOU NEED FOR ME TO DO? —bobnancyweber@gmail.com

Flags: needinfo?(bobnancyweber)

(In reply to bobnancyweber from comment #5)

Is this what you need?:

precisely

bp-b84fb8ea-fa5a-4884-b79b-8a90b0211014 35 minutes ago
bp-e359849d-5d91-4062-bb15-99d370211014 16 hours ago

The first several at least have crash signature @ AsyncShutdownTimeout | profile-change-teardown | Extension shutdown: bdThunderbird78@bitdefender.com

So perhaps bitdefender is the cause

Perhaps get rid of the stuff Bitdefender is inserting into Thunderbird and try without it. The first thing I see when I look at your crash is Thunderbird is unable to shut down because of an addon identified as bdThunderbird78@bitdefender.com

As a quick test, hold the shift key when you start Thunderbird to force it into troubleshooting mode and continue when prompted. This should prevent Bitdefender inserting code into Thunderbird's process.

Thunderbird crashes upon shut-down, even with the Bitdefender extension disabled. See bp-427a97a6-3e70-4804-a0cd-493e80211014

(In reply to bobnancyweber from comment #8)

Thunderbird crashes upon shut-down, even with the Bitdefender extension disabled. See bp-427a97a6-3e70-4804-a0cd-493e80211014

@ AsyncShutdownTimeout | profile-change-teardown | Extension shutdown: addoncompatibility@opto.one

They recently changed the shutdown signatures, so there is not yet a bug report for this. FWIW, I think you are the first person to report encountering a shutdown crash going from 78 to 91. Maybe try removing that addoncompatibiilty add-on?

Blocks: tb91found
Flags: needinfo?(bobnancyweber)

With the addoncompatibiilty add-on removed, and the Bitdefender extension still disabled, TB 91.2 shuts down just fine. Until the bug problem is resolved, would it be possible for me to “downgrade” from TB 91.2 to an earlier version that does not have this problem? I really do want a version of TB that will function correctly with the Bitdefender add-on enabled!

Flags: needinfo?(bobnancyweber)

Bitdefender is generally known to cause problems, so I would complain to them. In other words, I don't think it is likely this can be solved by changing Thunerbird code.

That said, try with bitdefender enabled and the addoncompatibility disabled and see what happens.
Also, what website has this addoncompatibility - what is the url?

Flags: needinfo?(bobnancyweber)

With Bitdefender re-enabled and the addoncompatibility removed, TB 91.2 crashes upon shut-down. Bitdefender has never caused a problem for me in previous versions of TB. Only now, after upgrading to version 91.2 have I experienced this problem. So, again I ask, would it be possible for me to “downgrade” from TB 91.2 to an earlier version that does not have this problem? How?

The Addon Compatibility Check for TB 91 is an add-on recommended by TB>Help>Add-ons and Themes>Recommendations.
https://addons.thunderbird.net/en-US/thunderbird/addon/addon-compatibility-check/

Flags: needinfo?(bobnancyweber)

The fact that these two add-ons independently seem to cause the crash makes me think that the problem is within TB, not the add-ons.

It's possible to start with --allow-downgrade
But, all data is not fully compatible so you'll need to get that data from backup (IIRC address book, and some calendar data).

Keeping the Compatibility addon disabled.
Did you completely remove the Bitdefender Spam Toolbar from Thunderbird and with Bitdefender enabled on computer, restart Thunderbird to see if it was specifically the Bitdefender Toolbar causing the problem? If no then please try it and report back on results
Over recent years Bitdefender has been known to cause many issues. Usually, it is a good idea to let Bitdefender know about them.

Flags: needinfo?(bobnancyweber)
Summary: Consistent crashes on shut down. → Consistent crashes on shut down. @ AsyncShutdownTimeout | profile-change-teardown | Extension shutdown: bdThunderbird78@bitdefender.com (and Extension shutdown: addoncompatibility@opto.one)

Yes, with both the Bitdefender and Compatibility Check add-ons completely removed from Thunderbird, and with Bitdefender enabled on the computer, Thunderbird 91.2 shuts down okay. However, with either of the add-ons installed and enabled, Thunderbird 91.2 crashes upon shut-down. Remember that the Compatibility Check for TB 91 is an add-on recommended by TB>Help>Add-ons and Themes>Recommendations
(https://addons.thunderbird.net/en-US/thunderbird/addon/addon-compatibility-check/). So the problem cannot be specifically and only Bitdefender. Please consider that there might well be a glitch in TB!

Flags: needinfo?(bobnancyweber)

Just to set some expectations, shutdown crashes historically don't have a track record of getting solved.

bp-b84fb8ea-fa5a-4884-b79b-8a90b0211014

0 mozglue.dll mozalloc_abort(char const* const)
1 xul.dll NS_DebugBreak(unsigned int, char const*, char const*, char const*, int)
2 xul.dll nsDebugImpl::Abort(char const*, int)
3 xul.dll XPTC__InvokebyIndex
4 @0x18bd935fa8f
5 xul.dll _tailMerge_d3dcompiler_47.dll
6 xul.dll static XPCWrappedNative::CallMethod(XPCCallContext&, XPCWrappedNative::CallMode)
7 xul.dll XPC_WN_CallMethod(JSContext*, unsigned int, JS::Value*)
8 xul.dll js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct, js::CallReason)
9 xul.dll Interpret(JSContext*, js::RunState&)
10 xul.dll js::RunScript(JSContext*, js::RunState&)
11 xul.dll js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct, js::CallReason)
12 xul.dll js::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, js::AnyInvokeArgs const&, JS::MutableHandle<JS::Value>, js::CallReason)
13 xul.dll PromiseReactionJob(JSContext*, unsigned int, JS::Value*)
14 xul.dll js::InternalCallOrConstruct(JSContext*, JS::CallArgs const&, js::MaybeConstruct, js::CallReason)
15 xul.dll js::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, js::AnyInvokeArgs const&, JS::MutableHandle<JS::Value>, js::CallReason)
16 xul.dll JS::Call(JSContext*, JS::Handle<JS::Value>, JS::Handle<JS::Value>, JS::HandleValueArray const&, JS::MutableHandle<JS::Value>)
17 xul.dll mozilla::dom::FinalizationRegistryCleanupCallback::Call(mozilla::dom::BindingCallContext&, JS::Handle<JS::Value>, mozilla::ErrorResult&)
18 xul.dll mozilla::PromiseJobRunnable::Run(mozilla::AutoSlowOperation&)
19 xul.dll mozilla::CycleCollectedJSContext::PerformMicroTaskCheckPoint(bool)
20 xul.dll mozilla::CycleCollectedJSContext::AfterProcessTask(unsigned int)

Severity: -- → S4
Component: Untriaged → General

Ever since upgrading to version 91.2.0 (64-bit) two weeks ago, Thunderbird consistently crashes on shut down.

Prior to 91.2.0, were you using 91.1.2? Or some flavor of version 91?

Flags: needinfo?(bobnancyweber)

Wayne et.al. Sorry I did not get back to you sooner about this. As you advised, I wrote to BitDefender. They replied, “IMAP is not supported with Bitdefender Anti-Spam, therefore it won't work with it. The server type that is supported by the Bitdefender feature is POP3.” So I guess the problem was not Thunderbird’s.

Flags: needinfo?(bobnancyweber)

So your crashing is gone?

Flags: needinfo?(bobnancyweber)

Yes. With the Bitdefender Anti-Spam add-on removed, Thunderbird no longer crashes on shut-down. You may close this ticket. Thanks for your assistance.

Flags: needinfo?(bobnancyweber)

Perhaps another example (among several) of bug 1674132
Keeping this open for now

See Also: → 1674132

This reproduces permanently here with Thunderbird 91.3.0 on Windows 8.1 as long as an add-on is active: [@ PromiseReactionJob ] https://crash-stats.thunderbird.net/report/bp-66382883-9a16-42e7-a9ec-cbf041211112
Bisection with mozregression reproduces the idling of 3 thunderbird.exe (main, gpu, extensions) but doesn't launch the crash reporter. Disabling add-ons in the add-ons manager fails: One gets the visual feedback an add-on gets disabled after the switch got clicked, but switching the view - either open the details page of an add-on and returning to the main view, or closing the add-ons manager and opening it again - will show them in enabled state again.

Mozregression logs these hangs:

2021-11-12T13:38:00.304000: INFO : application_display_name: Thunderbird Daily
2021-11-12T13:38:00.304000: INFO : application_id: {3550f703-e582-4d05-9a08-453d09bdfdc6}
2021-11-12T13:38:00.304000: INFO : application_name: Thunderbird
2021-11-12T13:38:00.304000: INFO : application_remotingname: thunderbird
2021-11-12T13:38:00.304000: INFO : application_repository: https://hg.mozilla.org/comm-central
2021-11-12T13:38:00.305000: INFO : application_version: 94.0a1
2021-11-12T13:38:00.305000: INFO : platform_buildid: 20210929104629
2021-11-12T13:38:00.305000: INFO : platform_changeset: fc5e583b2dd72ab893b81f9bfa34083346e247cc
2021-11-12T13:38:00.305000: INFO : platform_repository: https://hg.mozilla.org/mozilla-central
2021-11-12T13:38:00.305000: INFO : platform_version: 94.0a1
2021-11-12T13:38:01.422000: INFO : b'[NntpModuleLoader] Using nsNntpService.cpp'
2021-11-12T13:38:01.886000: INFO : b'console.warn: services.settings: Failed to load last_modified.json: TypeError: NetworkError when attempting to fetch resource.'
2021-11-12T13:38:02.388000: INFO : b"JavaScript error: resource://gre/modules/ExtensionCommon.jsm, line 510: NotFoundError: WindowGlobalChild.getActor: No such JSWindowActor 'Conduits'"
2021-11-12T13:38:02.390000: INFO : b'JavaScript error: moz-extension://42132615-85ec-4bbe-9db5-374b20030128/background.js, line 1: InvalidStateError: An exception was thrown'
2021-11-12T13:38:02.392000: INFO : b"JavaScript error: resource://gre/modules/ExtensionCommon.jsm, line 510: NotFoundError: WindowGlobalChild.getActor: No such JSWindowActor 'Conduits'"
2021-11-12T13:38:02.398000: INFO : b"JavaScript error: resource://gre/modules/ExtensionCommon.jsm, line 510: NotFoundError: WindowGlobalChild.getActor: No such JSWindowActor 'Conduits'"
2021-11-12T13:38:02.399000: INFO : b'JavaScript error: moz-extension://5d00b4a3-209b-4a2c-83d1-7b83c2977ae8/background.js, line 3: InvalidStateError: An exception was thrown'
2021-11-12T13:38:02.400000: INFO : b'JavaScript error: moz-extension://a2ba45f2-5f55-4e4f-b533-cc5412b83bfb/filtaquilla-background.js, line 6: InvalidStateError: An exception was thrown'
2021-11-12T13:38:02.401000: INFO : b"JavaScript error: resource://gre/modules/ExtensionCommon.jsm, line 510: NotFoundError: WindowGlobalChild.getActor: No such JSWindowActor 'Conduits'"
2021-11-12T13:38:02.402000: INFO : b"JavaScript error: resource://gre/modules/ExtensionCommon.jsm, line 510: NotFoundError: WindowGlobalChild.getActor: No such JSWindowActor 'Conduits'"
2021-11-12T13:38:02.405000: INFO : b"JavaScript error: resource://gre/modules/ExtensionCommon.jsm, line 510: NotFoundError: WindowGlobalChild.getActor: No such JSWindowActor 'Conduits'"
2021-11-12T13:38:15.529000: INFO : b"[calBackendLoader] Using Thunderbird's ical.js backend"
2021-11-12T13:38:15.621000: INFO : b'Warning: unrecognized command line flag -wait-for-browser'
2021-11-12T13:38:17.101000: INFO : b'JavaScript error: chrome://messenger/content/msgViewPickerOverlay.js, line 98: TypeError: can\'t access property "view", gFolderDisplay is null'
2021-11-12T13:38:38.766000: INFO : b'WARNING: At least one completion condition is taking too long to complete. Conditions: [{"name":"Extension shutdown: {9c21158b-2c76-4d0a-980a-c51fc9cefaa7}","state":{"state":"Startup: Run manifest, asyncEmitManifestEntry(\\"background\\")"},"filename":"resource://gre/modules/addons/XPIProvider.jsm","lineNumber":2620,"stack":["resource://gre/modules/addons/XPIProvider.jsm:startup/<:2620","resource://gre/modules/AsyncShutdown.jsm:observe:575"]},{"name":"Extension shutdown: tbsortfolders@xulforum.org","state":{"state":"Startup: Run manifest, asyncEmitManifestEntry(\\"background\\")"},"filename":"resource://gre/modules/addons/XPIProvider.jsm","lineNumber":2620,"stack":["resource://gre/modules/addons/XPIProvider.jsm:startup/<:2620","resource://gre/modules/AsyncShutdown.jsm:observe:575"]},{"name":"Extension shutdown: filtaquilla@mesquilla.com","state":{"state":"Startup: Run manifest, asyncEmitManifestEntry(\\"background\\")"},"filename":"resource://gre/modules/addons/XPIProvider.jsm","lineNumber":2620,"stack":["resource://gre/modules/addons/XPIProvider.jsm:startup/<:2620","resource://gre/modules/AsyncShutdown.jsm:observe:575"]}] Barrier: profile-change-teardown'
2021-11-12T13:39:29.766000: INFO : b'FATAL ERROR: AsyncShutdown timeout in profile-change-teardown Conditions: [{"name":"Extension shutdown: {9c21158b-2c76-4d0a-980a-c51fc9cefaa7}","state":{"state":"Startup: Run manifest, asyncEmitManifestEntry(\\"background\\")"},"filename":"resource://gre/modules/addons/XPIProvider.jsm","lineNumber":2620,"stack":["resource://gre/modules/addons/XPIProvider.jsm:startup/<:2620","resource://gre/modules/AsyncShutdown.jsm:observe:575"]},{"name":"Extension shutdown: tbsortfolders@xulforum.org","state":{"state":"Startup: Run manifest, asyncEmitManifestEntry(\\"background\\")"},"filename":"resource://gre/modules/addons/XPIProvider.jsm","lineNumber":2620,"stack":["resource://gre/modules/addons/XPIProvider.jsm:startup/<:2620","resource://gre/modules/AsyncShutdown.jsm:observe:575"]},{"name":"Extension shutdown: filtaquilla@mesquilla.com","state":{"state":"Startup: Run manifest, asyncEmitManifestEntry(\\"background\\")"},"filename":"resource://gre/modules/addons/XPIProvider.jsm","lineNumber":2620,"stack":["resource://gre/modules/addons/XPIProvider.jsm:startup/<:2620","resource://gre/modules/AsyncShutdown.jsm:observe:575"]}] At least one completion condition failed to complete within a reasonable amount of time. Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources.'
Status: UNCONFIRMED → NEW
Crash Signature: [@ PromiseReactionJob ]
Ever confirmed: true

The last line is at least helpful in saying why the crash happens... "Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources."

Is this a dupe of Bug 1732515 ?

Summary of that bug: Broken add-ons and crash-on-shutdown if profile has the online-offline prompt enabled during Thunderbird start. It can be mitigated, if the prompt is disabled.

I hope that gets uplifted soon.

(In reply to John Bieling (:TbSync) from comment #26)

Is this a dupe of Bug 1732515 ?

I hope that gets uplifted soon.

Maybe. Time will tell. Thunderbird 95.0b2: shipped Tuesday, three days ago. No regressions discovered so far.

Rob, does this apply cleanly to esr91?

Flags: needinfo?(rob)

(In reply to Wayne Mery (:wsmwk) from comment #27)

(In reply to John Bieling (:TbSync) from comment #26)

Is this a dupe of Bug 1732515 ?
Rob, does this apply cleanly to esr91?

Yeah, bug 1732515 will apply clearly on esr91. Please request uplift ASAP to get it into 91.3.1.

Flags: needinfo?(rob)

Reporter - when was your last crash?

  • Did your crashing stop with 91.3.1 circa Nov 14 (but throttled on Nov 16), or 91.3.2 circa Nov 18?
  • Or perhaps later, with 91.4.0 circa Dec 7?
Flags: needinfo?(bobnancyweber)

(In reply to Wayne Mery (:wsmwk) from comment #29)

Reporter - when was your last crash?

  • Did your crashing stop with 91.3.1 circa Nov 14 (but throttled on Nov 16), or 91.3.2 circa Nov 18?
  • Or perhaps later, with 91.4.0 circa Dec 7?

Nevermind, I forgot to check your earlier comments.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(bobnancyweber)
Resolution: --- → DUPLICATE
Summary: Consistent crashes on shut down. @ AsyncShutdownTimeout | profile-change-teardown | Extension shutdown: bdThunderbird78@bitdefender.com (and Extension shutdown: addoncompatibility@opto.one) → Consistent crashes @ AsyncShutdownTimeout | profile-change-teardown | Extension shutdown: bdThunderbird78@bitdefender.com - "Causing a crash to ensure that we do not leave the user with an unresponsive process draining resources."
Duplicate of bug: 1732515
You need to log in before you can comment on or make changes to this bug.