Closed Bug 1735822 Opened 1 year ago Closed 27 days ago

unread threads disappear. hangs with beta 94

Categories

(Thunderbird :: Folder and Message Lists, defect)

Thunderbird 91
x86_64
Windows 10
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: arthur, Unassigned, NeedInfo)

References

(Depends on 1 open bug, )

Details

(Whiteboard: [closeme 2022-09-21])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.81 Safari/537.36

Steps to reproduce:

A few days after upgrading to the final version of Thunderbird it stopped loading. There is a bug in the final version which I am waiting to get fixed. I am currently using the latest beta (94.0b2) as a work around.

Actual results:

When I select view / threads / threads with unread I now see all threads including read messages displayed.

If I select view / threads / unread then no messages are displayed. The screen is blank.

Expected results:

I should only see unread messages.

So this isn't working in the beta you filed the bug report for, or in version 91.2.0?

I don't see an issue in my 91.2.0, but I will admit I'm not that familiar with that usage, preferring to use the Quick Filter Unread button.

Does the same issue occur using Help > Troubleshoot Mode?

Could be an extension causing a problem.

Component: Untriaged → Message Reader UI
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

I can't get the release version to load. That's why I'm using the beta. The issues I'm experiencing are with the beta. When the beta loads it shows both read and unread messages. Normal behavior is when I select "threads with unread" to only show unread messages, unless display "all" messages is specifically selected under threads. If I go into view and change it to "unread" only unread messages should be shown. But instead the view seems to crash and no message are displayed at all, and it is not possible to change the view setting without first exiting the newsgroup. None of this is normal behavior.

I don't normally install and run beta software. This is just a workaround until the released version fixes the other bug that keeps crashing it whenever I try to use it.

I already submitted the crash reports for 91.2.0 here: https://support.mozilla.org/en-US/questions/1353522?utm_campaign=questions-reply&utm_source=notification&utm_medium=email#answer-1450051

These crash IDs are for the release version 91.2.0, not the beta. The beta hasn't generated any crash IDs that I'm aware of. It just locks up when I try to view unread messages only.

But here are some of the 91.2.0 crash IDs:

Crash ID: bp-1c6089e6-e537-4de1-8bed-488210211010

Crash ID: bp-e25c3118-84ba-4649-8ce2-3a4d80211011

Crash ID: bp-955ce33f-8e3d-4038-8411-160a90211011

(In reply to Arthur from comment #4)

I already submitted the crash reports for 91.2.0 here: https://support.mozilla.org/en-US/questions/1353522?utm_campaign=questions-reply&utm_source=notification&utm_medium=email#answer-1450051

These crash IDs are for the release version 91.2.0, not the beta. The beta hasn't generated any crash IDs that I'm aware of. It just locks up when I try to view unread messages only.

We call that a hang.

But here are some of the 91.2.0 crash IDs:

Crash ID: bp-1c6089e6-e537-4de1-8bed-488210211010
Crash ID: bp-e25c3118-84ba-4649-8ce2-3a4d80211011
Crash ID: bp-955ce33f-8e3d-4038-8411-160a90211011

This is Bug 1732549 - Crash using newsgroup after View > Threads > Unread - the fix should appear in 91.2.1 next week. None of these crash reports have THunderbird started in troublehshoot mode - you didn't clearly state that you attempted that.

OTOH, that fix might cause the thread problem you are seeing in this bug report.
Does it happen in Troubleshoot mode?
If you use Unified Folder view (View > Folder) does problem go away if you turn off unified?

Flags: needinfo?(arthur)

With the released version it crashed in troubleshooting mode too. I have a folder full of crash IDs. I only posted a few.

It didn't occur to me to try troubleshooting mode with the beta. I just loaded the beta with troubleshooting mode and it still hangs. But I'm happy to see 91.2.1 is coming next week. Hopefully I can install that and everything will go back to normal.

Flags: needinfo?(arthur)

WFM on trunk.

Depends on: 1732549

Crashes are gone for 91.2.1?
Are you still having trouble with threads or hangs on beta?

Flags: needinfo?(arthur)
Summary: unread threads disappear → unread threads disappear. crashes with 91.2.0. hangs with beta 94

I am now using the new release version. The new release version is having the exact same problem that the beta version has. It will not display unread messages only, and hangs when I try. If I select threads with unread, it shows all the read messages too. I've been meaning to submit a new bug report for the release version, just haven't gotten around to it yet. But I'm assuming whatever bug this is in the beta, if it's identified and fixed in the beta, it will also be fixed in the next release update too.

Flags: needinfo?(arthur)

I'm removing crash from the summary because that issue is gone

Summary: unread threads disappear. crashes with 91.2.0. hangs with beta 94 → unread threads disappear. hangs with beta 94
Component: Message Reader UI → Folder and Message Lists
Version: Thunderbird 94 → Thunderbird 91
Depends on: 1732816

Arthur do you still see this problem

Flags: needinfo?(arthur)
Whiteboard: [closeme 2022-09-21]

Thank you for asking. Unfortunately yes, I still have the problem. I've been using Thunderbird for many years without problem. But for almost a year now I have not been able to set the view to "unread." I just checked again. When I switched the view to "unread" the entire screen went empty. I have to set the view to "threads with unread" which means instead of just seeing the new messages I also get all of the already read messages too.

Status: UNCONFIRMED → RESOLVED
Closed: 27 days ago
Flags: needinfo?(arthur)
Resolution: --- → WONTFIX

(In reply to Arthur from comment #12)

Thank you for asking. Unfortunately yes, I still have the problem. I've been using Thunderbird for many years without problem. But for almost a year now I have not been able to set the view to "unread." I just checked again. When I switched the view to "unread" the entire screen went empty. I have to set the view to "threads with unread" which means instead of just seeing the new messages I also get all of the already read messages too.

I've come across a similar case in Support Forum:
https://support.mozilla.org/en-US/questions/1387439
Try the solution offered at that link as it may help you.

Flags: needinfo?(arthur)
You need to log in before you can comment on or make changes to this bug.