Closed Bug 1735938 Opened 4 months ago Closed 3 months ago

account setup: Re-test => Every other account created drops SMTP server setting showing Port 0

Categories

(Thunderbird :: Account Manager, defect)

Thunderbird 91
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird95+ fixed)

RESOLVED FIXED
96 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird95 + fixed

People

(Reporter: edwardp, Assigned: mkmelin)

References

Details

Attachments

(2 files)

Attached image snapshot84.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:93.0) Gecko/20100101 Firefox/93.0

Steps to reproduce:

Installed Thunderbird (Snap) package, version 91.2.0, it starts with a new profile. Upon adding accounts, it adds the first account without issue. In adding the second account and every other account after the second (the fourth, sixth, eighth, etc.), once Re-Test is selected, Thunderbird drops the SMTP server setting to just the domain name, displaying Port 0. Multiple attempts at account creation must be made before Thunderbird will eventually save the account.

Actual results:

SMTP server setting changes upon Re-Test selection, showing Port 0

Expected results:

SMTP server setting should have remained as originally input, showing the correct port number, not Port 0 and Thunderbird should have saved the account.

Screenshot attached showing the issue.

Summary: Every other account created drops SMTP server setting showing Port 0 → account setup: Re-test => Every other account created drops SMTP server setting showing Port 0

I'm not able to reproduce this.
No matter how many times I click on Re-Test the settings are not changed.

If I manually set the hostname to .comcast.net and "Connection security" to Autodetect (PORT: 0), after clicking Re-Test, the fields are updated properly with smtp.comcast.net and "Connection security" to STARTTLS.

Assignee: nobody → alessandro
Assignee: alessandro → nobody

Based on Alessandro's comment, it would appear that the Account Manager still isn't working as intended?

I had this installed on Debian 11 (bullseye, 64-bit).

Based on Alessandro's comment, it would appear that the Account Manager still isn't working as intended?

What does the Account Manager have anything to do with the reported issue?
This is related to the account setup and the autoconfig feature.

What I reported in comment 1 was the fact that I'm not able to reproduce your error.
The autoconfig never updates the port to 0 and always returns a correct configuration.

My apologies, Account Manager should have read account setup.

This happens if you try to set up another account and the (similar) smtp is already set.

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Duplicate of this bug: 1740110

Thanks, Magnus! I did a search before submitting my report, but apparently my search terms were not good.

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/12b11ec601cc
for account setup manual edit, honor the user set port when re-testing. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Comment on attachment 9250190 [details]
Bug 1735938 - for account setup manual edit, honor the user set port when re-testing. r=aleca

[Approval Request Comment]
Regression caused by (bug #): ancient/unknown
User impact if declined: Confusion when doing manual account setup in some cases
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): Small non-risky change

Attachment #9250190 - Flags: approval-comm-esr91?
Attachment #9250190 - Flags: approval-comm-beta?

Comment on attachment 9250190 [details]
Bug 1735938 - for account setup manual edit, honor the user set port when re-testing. r=aleca

[Triage Comment]
Approved for beta

Attachment #9250190 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9250190 [details]
Bug 1735938 - for account setup manual edit, honor the user set port when re-testing. r=aleca

[Triage Comment]
Approved for esr91

Attachment #9250190 - Flags: approval-comm-esr91? → approval-comm-esr91+
You need to log in before you can comment on or make changes to this bug.