about:config shows a blank page.

VERIFIED DUPLICATE of bug 98667

Status

SeaMonkey
Preferences
VERIFIED DUPLICATE of bug 98667
15 years ago
13 years ago

People

(Reporter: Rob North, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
Build: 2002100108

Steps to reporduce:
  type about:config in the toolbar.
Result:
   blank page
Expected results:
  As Mozilla 1.0 FAQ says in section 1.5:
  entering about:config in the address bar will list every configurable 
  variable in Mozilla.
Repeatability:
  Tried 3 times.

This bug is definately a regression to bug 129114 behavour.
Possibly regression to bug 127252.

Comment 1

15 years ago
worksforme with linux trunk build 20021007
(Reporter)

Comment 2

15 years ago
Tried on same build but on Win 98:works.

Comment 3

15 years ago
Have you enabled Javascript (i think thats required for that, try also
about:plugins, about: and about:mozilla)? 
(Reporter)

Comment 4

15 years ago
Still showing blank page.
Javascript is enabled for Browser, but disabled for Mail/News.
about:plugins & about:mozilla still work.
Although they now appear dirrerent:
  plugins... nice & stylish.
  mozilla... something about "the beast of mozilla". Verry silly. Verry ominous.

(Reporter)

Comment 5

15 years ago
Just tried on default profile.
Works fine.

On my working profile, fails.
Suggestions as to where to look in profiles dir for differences would be
appreciated.
(Reporter)

Comment 6

15 years ago
Did some more digging...

Opened the javascript console & saw the following loading the page "about:config":

Error: uncaught exception: [Exception... "Component returned failure code:
0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult:
"0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame ::
chrome://global/content/config.js :: onConfigLoad :: line 155"  data: no]

Tried running with JS debugger active:

It appears that the prefBranch.getCharPref("plugin.soname.list") throws
the exception.

If can live without the preference value, this bug could probably be fixed
by using at try catch statement (or whatever JS uses to handle exceptions),
and in catch statement set prefValue to an error string.

now, what is "plugin.soname.list" and why does it return an exception on my
profile, and not on the default profile?
(Reporter)

Comment 7

15 years ago
This is definately a duplicate 100% match!

*** This bug has been marked as a duplicate of 98667 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.