command-w closes cookie confirmation dialog, freezes app

VERIFIED FIXED

Status

Camino Graveyard
Tabbed Browsing
--
major
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Michael Blakeley, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({hang})

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; rv:1.0.1) Gecko/20021008 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; rv:1.0.1) Gecko/20021008 Chimera/0.5+

Browsing with "ask before storing a cookie" preference, the cookie confirmation
dialog accepts command-w for "close". The dialog window closes, but the browser
is still waiting for Yes/No buttons to be pressed, and will not respond.

Browser must be force-quit and relaunched to proceed.

Reproducible: Always

Steps to Reproduce:
1. set "ask before storing a cookie" preference
2. clear all cookies
3. go to a site that sets a cookie
4. when the cookie confirmation dialog appears, hit command-w

Actual Results:  
confirmation dialog closes, whereupon the browser UI is frozen and does not respond

Expected Results:  
confirmation dialog should ignore command-w

Setting "Major" because user must force-quit app to proceed, so there's a
possible loss of data in open windows. It's easy to accidentally trigger this
behavior in tabbed-browsing load-in-background mode, and then you've lost the
contents of all your tabs.

Comment 1

16 years ago
WorksForMe using Chimera/2002100304 on 10.1.5. Command+w doesn't dismiss the dialog.
(Reporter)

Comment 2

16 years ago
More detail: Ordinary cookie confirmation window is fine - no problem there.

The problem report is for cookie-confirmation windows from a tab loading content
in the background. This "background cookie" window actually shows a red gumdrop
(close widget) and also responds to command-w.

So the "steps to reproduce" needs to include setting your browser for "load
windows in new tabs" and "load tabs in the background". Then command-click on a
site that tries to set a cookie, and isn't in cookperm.txt

Comment 3

16 years ago
Confirmed using Chimera/2002100304 on 10.1.5. Reassigning to Tabbed Browsing to
start.
Assignee: saari → pinkerton
Status: UNCONFIRMED → NEW
Component: General → Tabbed Browsing
Ever confirmed: true
QA Contact: winnie → sairuh
(Assignee)

Comment 4

15 years ago
easy nib change. fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Keywords: hang
using 2002.11.04.04 on 10.2.1, cmd-W is ignored with the cookie confirmation
sheet. vrfy'ing as fixed.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.