Closed Bug 1736419 Opened 3 years ago Closed 2 years ago

Certificate error page buttons should match Figma spec

Categories

(Firefox :: Theme, defect)

defect

Tracking

()

RESOLVED FIXED
97 Branch
Tracking Status
firefox97 --- fixed

People

(Reporter: mtigley, Assigned: huangs50, NeedInfo)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Attached image dark_hcm.PNG

The actions buttons on the expired certificate error page should match the Figma spec when HCM is enabled for both White and Dark contrast themes. See here.

Assignee: nobody → huangs50
Status: NEW → ASSIGNED
Attached image light_hcm.PNG

The severity field is not set for this bug.
:dao, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(dao+bmo)

It looks like the current primary button is using primarily SelectedItem* system OS colors: https://searchfox.org/mozilla-central/rev/1e7f7235cf822e79cd79ba9e200329ede3d37925/toolkit/themes/shared/in-content/common.inc.css#227-232.

To match the Figma spec, we'd have to use ButtonText and ButtonFace for the background-color and text color, respectively. And of course invert those for the :hover and :active states.

Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/944a0f7c8920
Certificate error page buttons should match Figma spec. r=mtigley,desktop-theme-reviewers,harry
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 97 Branch
Regressions: 1770923
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: