chimera will not start up

RESOLVED DUPLICATE of bug 173311

Status

--
blocker
RESOLVED DUPLICATE of bug 173311
16 years ago
16 years ago

People

(Reporter: isaac, Assigned: saari)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.22; Mac_PowerPC)
Build Identifier: Navigator 0.50 Build Id: 2002090913

Chimera was working fine. I downloaded a new nightly build manually and ran it.
This nightly build crashed immediately. I removed it. I re-installed the original
Chimera (Navigator 0.50 Build Id: 2002090913) it also crashed immediately.
I saved my bookmarks and removed all other chimera files. I even removed
what I think is all trace of Mozilla to be sure. Still will not start up.
There is a crash log.
It is reproduced here. Okay, so how do I recover.
I did an fsck manually and found no problems. I fixed
disc privilges by booting off the Jaguar CD 
(I note though parenthetically that the /usr/man privileges never get fixed even though
it claims they do get fixed)

I guess I could run disk warrior, but I don't believe this is a disk
problem. 

Date/Time:  2002-10-10 14:17:29 +1000
OS Version: 10.2.1 (Build 6D52)
Host:       isaac.cs.rmit.edu.au

Command:    Navigator
PID:        476

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000014

Thread 0 Crashed:
 #0   0x0400bb80 in js_AtomizeString
 #1   0x0400bd78 in js_Atomize
 #2   0x04007020 in JS_InternString
 #3   0x003d4d58 in nsScriptSecurityManager::nsScriptSecurityManager(void)
 #4   0x003d5010 in nsScriptSecurityManager::GetScriptSecurityManager(void)
 #5   0x0005bf70 in Construct_nsIScriptSecurityManager(nsISupports *, nsID const &, 
void **)
 #6   0x0509801c in nsGenericFactory::CreateInstance(nsISupports *, nsID const &, void 
**)
 #7   0x0504b80c in nsComponentManagerImpl::CreateInstanceByContractID(char const 
*, nsISupports *, nsID const &, void **)
 #8   0x05099b5c in nsCreateInstanceByContractID::operator()(nsID const &, void **) 
const
 #9   0x0509755c in nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const &, 
nsID const &)
 #10  0x0013cb40 in nsAppStartupNotifier::Observe(nsISupports *, char const *, 
unsigned short const *)
 #11  0x00047a88 in NS_InitEmbedding(nsILocalFile *, nsIDirectoryServiceProvider *)
 #12  0x000303a4 in -[PreferenceManager initMozillaPrefs]
 #13  0x0002ff98 in -[PreferenceManager init]
 #14  0x0002ff00 in +[PreferenceManager sharedInstance]
 #15  0x00008b74 in -[MainController preferenceManager]
 #16  0x00007564 in -[MainController applicationDidFinishLaunching:]
 #17  0x907eaf7c in _nsNotificationCenterCallBack
 #18  0x90168b18 in _postNotification
 #19  0x90166238 in _CFNotificationCenterPostLocalNotification
 #20  0x930c9898 in -[NSApplication _sendFinishLaunchingNotification]
 #21  0x930c0060 in _requiredAEEventHandler
 #22  0x91b56e4c in aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, 
unsigned char*)
 #23  0x91b597f0 in dispatchEventAndSendReply(AEDesc const*, AEDesc*)
 #24  0x91b56d5c in aeProcessAppleEvent
 #25  0x92c82d30 in AEProcessAppleEvent
 #26  0x93082350 in _DPSNextEvent
 #27  0x930ccf84 in -[NSApplication 
nextEventMatchingMask:untilDate:inMode:dequeue:]
 #28  0x930ca500 in -[NSApplication run]
 #29  0x930d2598 in NSApplicationMain
 #30  0x00005024 in main
 #31  0x00004ed4 in _start
 #32  0x00004d04 in start

PPC Thread State:
  srr0: 0x0400bb80 srr1: 0x0200f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x0400bb80  ctr: 0x00000000   mq: 0x00000000
    r0: 0x0400bb80   r1: 0xbfffe320   r2: 0x005f005f   r3: 0x0657aa22
    r4: 0xbfffe3d0   r5: 0x00000082   r6: 0x00000002   r7: 0x00000002
    r8: 0x65720000   r9: 0x0657aa50  r10: 0xbfffe3e4  r11: 0x00000072
   r12: 0x0405b788  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0xbfffe794  r19: 0xbfffe788
   r20: 0xbfffe790  r21: 0xbfffe7a8  r22: 0x0081c724  r23: 0x00000082
   r24: 0x00936dd0  r25: 0xffffffff  r26: 0x00000000  r27: 0xbfffe3d8
   r28: 0x00000006  r29: 0xbfffe3d0  r30: 0x00000002  r31: 0x003d4ca8
Date/Time:  2002-10-10 14:17:29 +1000
OS Version: 10.2.1 (Build 6D52)
Host:       isaac.cs.rmit.edu.au

Command:    Navigator
PID:        476

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000014

Thread 0 Crashed:
 #0   0x0400bb80 in js_AtomizeString
 #1   0x0400bd78 in js_Atomize
 #2   0x04007020 in JS_InternString
 #3   0x003d4d58 in nsScriptSecurityManager::nsScriptSecurityManager(void)
 #4   0x003d5010 in nsScriptSecurityManager::GetScriptSecurityManager(void)
 #5   0x0005bf70 in Construct_nsIScriptSecurityManager(nsISupports *, nsID const &, 
void **)
 #6   0x0509801c in nsGenericFactory::CreateInstance(nsISupports *, nsID const &, void 
**)
 #7   0x0504b80c in nsComponentManagerImpl::CreateInstanceByContractID(char const 
*, nsISupports *, nsID const &, void **)
 #8   0x05099b5c in nsCreateInstanceByContractID::operator()(nsID const &, void **) 
const
 #9   0x0509755c in nsCOMPtr_base::assign_from_helper(nsCOMPtr_helper const &, 
nsID const &)
 #10  0x0013cb40 in nsAppStartupNotifier::Observe(nsISupports *, char const *, 
unsigned short const *)
 #11  0x00047a88 in NS_InitEmbedding(nsILocalFile *, nsIDirectoryServiceProvider *)
 #12  0x000303a4 in -[PreferenceManager initMozillaPrefs]
 #13  0x0002ff98 in -[PreferenceManager init]
 #14  0x0002ff00 in +[PreferenceManager sharedInstance]
 #15  0x00008b74 in -[MainController preferenceManager]
 #16  0x00007564 in -[MainController applicationDidFinishLaunching:]
 #17  0x907eaf7c in _nsNotificationCenterCallBack
 #18  0x90168b18 in _postNotification
 #19  0x90166238 in _CFNotificationCenterPostLocalNotification
 #20  0x930c9898 in -[NSApplication _sendFinishLaunchingNotification]
 #21  0x930c0060 in _requiredAEEventHandler
 #22  0x91b56e4c in aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, 
unsigned char*)
 #23  0x91b597f0 in dispatchEventAndSendReply(AEDesc const*, AEDesc*)
 #24  0x91b56d5c in aeProcessAppleEvent
 #25  0x92c82d30 in AEProcessAppleEvent
 #26  0x93082350 in _DPSNextEvent
 #27  0x930ccf84 in -[NSApplication 
nextEventMatchingMask:untilDate:inMode:dequeue:]
 #28  0x930ca500 in -[NSApplication run]
 #29  0x930d2598 in NSApplicationMain
 #30  0x00005024 in main
 #31  0x00004ed4 in _start
 #32  0x00004d04 in start

PPC Thread State:
  srr0: 0x0400bb80 srr1: 0x0200f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x0400bb80  ctr: 0x00000000   mq: 0x00000000
    r0: 0x0400bb80   r1: 0xbfffe320   r2: 0x005f005f   r3: 0x0657aa22
    r4: 0xbfffe3d0   r5: 0x00000082   r6: 0x00000002   r7: 0x00000002
    r8: 0x65720000   r9: 0x0657aa50  r10: 0xbfffe3e4  r11: 0x00000072
   r12: 0x0405b788  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0xbfffe794  r19: 0xbfffe788
   r20: 0xbfffe790  r21: 0xbfffe7a8  r22: 0x0081c724  r23: 0x00000082
   r24: 0x00936dd0  r25: 0xffffffff  r26: 0x00000000  r27: 0xbfffe3d8
   r28: 0x00000006  r29: 0xbfffe3d0  r30: 0x00000002  r31: 0x003d4ca8


Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Known issue.

*** This bug has been marked as a duplicate of 173311 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.