Closed Bug 1736613 Opened 1 year ago Closed 11 months ago

[meta] Port archived MDN docs to firefox-source-docs

Categories

(Firefox :: General, task)

task

Tracking

()

RESOLVED DUPLICATE of bug 1617963

People

(Reporter: jhirsch, Assigned: jhirsch)

Details

(Keywords: meta)

Summary

Metabug to capture work to port individual pages from the MDN archived Firefox/Gecko docs to firefox-source-docs. File a bug when you grab a page.

Background

The MDN team removed Gecko and Mozilla internals from MDN last year. There are about 8000 pages in the archive, with varying age and accuracy/staleness. Some of the pages are useful for historical reference, it's unclear what we want to do with those. However, some other pages usefully document how Gecko and Firefox work today, and those are clearly worth pulling into the maintained firefox-source-docs repository.

Next Steps

Right now, there's work underway to generate a comprehensive list of docs worth porting.

In the meantime, feel free to file a bug here if you see a page you would like to pull over.

The archived repo is here: https://github.com/mdn/archived-content/tree/main/files/en-us

I'll include a link to the megadoc when it's been narrowed down further (hopefully down to 500-1000 pages of possible interest), and when we identify the (say) 50 most valuable pages, we'll plan to file bugs for those under this metabug.

Keywords: meta
Summary: [metabug] Port archived MDN docs to firefox-source-docs → [meta] Port archived MDN docs to firefox-source-docs

It turns out there's also a related bug 1617963 that was filed against the build :: docs component.

I'm not sure of the best division of labor between the two metabugs; comments / suggestions welcome.

Depends on: 1736870
Depends on: 1737859
Assignee: nobody → jhirsch
Depends on: 1739710

I'm not sure of the best division of labor between the two metabugs; comments / suggestions welcome.

I went ahead and marked this one as dupe (the other has been around for 2 years and has a lot of dependencies already)

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: migrate-from-mdn
No longer depends on: 1737859
No longer depends on: 1736870
No longer depends on: 1739710
You need to log in before you can comment on or make changes to this bug.