Closed Bug 1736615 Opened 3 months ago Closed 3 months ago

Firefox installed from Microsoft Store breaks after restart

Categories

(Firefox :: Untriaged, defect)

x86_64
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1730498

People

(Reporter: sgalich, Unassigned)

References

(Blocks 1 open bug)

Details

STR:

  1. install FF from the Store while having FF classic installed on the system
  2. run it
  3. sign into the FF-account
  4. close FF
  5. open FF again

After a few seconds there will be warning icon in FF menu, FF account is disconnected and browser console will be full of errors related to inability to rename files or find files in the profile.

OperationError: Could not move temporary file(C:\Users\Sergey\AppData\Roaming\Mozilla\Firefox\Profiles\jbw8tsnl.default-release-1634649966464\sessionCheckpoints.json.tmp) to destination(C:\Users\Sergey\AppData\Roaming\Mozilla\Firefox\Profiles\jbw8tsnl.default-release-1634649966464\sessionCheckpoints.json)

Same happens when I create a new profile and launch it.

  • Windows Settings > Apps > Firefox > Repair does not help
  • Windows Settings > Apps > Firefox > Reset does not help
  • Uninstall + Install does not help
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

serg: thanks for the report. Exactly what version of Windows are you using? This looks a lot like a pre-release specific Windows issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1730498. Can you see if that could apply to you?

Flags: needinfo?(sgalich)

Correct, this is exactly what happens in 1730498

Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(sgalich)
Resolution: --- → DUPLICATE
Duplicate of bug: 1730498
You need to log in before you can comment on or make changes to this bug.