The "filterFolderDeniedLocked" message (user-unfriendly, appears too often, unpredictable)

RESOLVED WORKSFORME

Status

MailNews Core
Filters
RESOLVED WORKSFORME
15 years ago
7 years ago

People

(Reporter: Dave Evans, Assigned: Navin Gupta)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
The "filterFolderDeniedLocked" message ("The messages could not be filtered to
folder '%S' because another operation is in progress") appears all too often,
and doesn't appear (to an un-savvy user like me) to be triggered by anything in
particular.  Thus I don't know what I could do differently to make it go away
(apart from not use filters).

When it happened to me just now, I had ~190 messages in my POP3 box, and it
generated that message for *each e-mail* for probably the first 40 messages. 
(Then presumably the lock became available, because the message went away).

So, my request(s):

- if possible, can the message just not be shown at all (silently wait until the
lock is available, or whatever)

- otherwise, if we take it as read that the message *must* be shown, then

     - can it only be shown "once per download", rather than for each message?

     - can it be reworded to explain that "some messages in your 'XYZ-Inbox'
folder were not filtered".
(Reporter)

Comment 1

15 years ago
*** Bug 173675 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

15 years ago
I haven't seen this error message for several weeks, so I assume it's now fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: MailNews → Core
Product: Core → MailNews Core

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.