Snoozing and acknowledge events

RESOLVED WORKSFORME

Status

Calendar
Sunbird Only
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Paulo Cruz, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
I'm using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a)
Gecko/20020910 and Calendar 2002092009-cal, and i'm having the following
problems with alarms:

1. When you have several alarms and acknowledge some and snooze others
(including for different intervals), after the passed time for the shorter
interval they all appear;

2. For alarms set to a determined hour, but at that hour the computer isn't
working, it should appear those alarms right after starting calendar.

Comment 1

15 years ago
Can you please attach your .ics file here or give the exact steps to reproduce
the first bug?
The second part of this bug (please put only 1 problem per bug report) is
already in bugzilla.
(Reporter)

Comment 2

15 years ago
The steps to simulate the first bug are:

Create two events for the same date and hour with an alarm. Then when those 2
alarms appear, snooze one of them and aknowledge the other. After the time you
set to the snooze has passed, both alarms appears again.

Hope this is enough.

Comment 3

15 years ago
Confirmed. -> Mostafa.
Assignee: mikep → mostafah
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

13 years ago
This is the most annoying thing about the calendar. It appears to have been like
this for well over a year as well. I always close the calendar and reopen it to
get it to quit doing this to me.

Comment 5

13 years ago
I've also experienced this bug. 

Comment 6

13 years ago
I'm having this bug too; I've just reinstalled Sunbird after several months,
hoping it had been fixed, and (after only one day of using it) am tempted to
uninstall it again.  This is absolutely the single most annoying bug of any
program on my computer.

(In reply to comment #5)
> I've also experienced this bug. 

Comment 7

13 years ago
I to am experiencing this problem.  Notice that same start time is not required
for this to happen.  This will happen any time a new alarm pops up and another
alarm has been snoozed.  I tend to set my alarms quite a bit ahead of time so it
is common for me to end up snoozing multiple alarms simultaneously.  Trying to
give different snooze times or acknowledging any of the alarms is fruitless:
they all pop back up with the soonest snooze.

Comment 8

13 years ago
Created attachment 186203 [details] [diff] [review]
Proposed fix

Fixes calendarOverlay.js to remove event from pending events array when event
passed to alert dialog window.	Fixes calendarOverlay.js to prevent adding
duplicate events to pending events array.  Fixes alertDialog.js to get snooze
units from alarm being snoozed instead of first alarm displayed.

Comment 9

13 years ago
This annoyed me enough yesterday with five events popping up over and over again
despite some being snoozed for days.  I noticed that a workaround is to close
Sunbird immediately after snoozing the events and then reopening it and all
seems to work fine.  That pointed me to the display code.  It appears tha
calenderOverlay.js keeps an array of pending events but never removes any events
from the array.  I added code to remove the events when it passes them to the
alert dialog window.  Also added code to prevent adding multiple events to the
array.  This also exposed another bug in alertDialog.js where it always grabs
the snooze units from the first displayed alarm instead of the one being snoozed.

I'm not CVS literate so I apologize for a diff file that probably isn't exactly
what it should be (directory paths and stuff will be goofy).  This fix was
tested on Sunbird 0.2 Windows XP and probably needs some additional testing.

I believe this also fixes bugs 250148, 249926 and 238817.
(In reply to comment #9)
> I'm not CVS literate so I apologize for a diff file that probably isn't exactly
> what it should be (directory paths and stuff will be goofy).  This fix was
> tested on Sunbird 0.2 Windows XP and probably needs some additional testing.

Hi Ralph, 
thanks for the patch. 

It would be best if you could create your diffs against the Mozilla CVS tree.
See http://www.mozilla.org/cvs.html on how to get the Mozilla source code. You
will just need the calendar directory.

It would also be great if you test your patch against a recent trunk build.
Sunbird 0.2 is pretty old by now and a lot of development has happened since.
You can get newer builds at
http://ftp.mozilla.org/pub/mozilla.org/calendar/sunbird/contrib/

Comment 11

12 years ago
Hello, I am new to everything that is Mozilla, I use now Thunderbird and I 
like it. I use Sunbird since 2 days and I love it, it really improved muy 
productivity and organization. Unfortunately the alarms are not being snoozed, 
they come up every minute, even if I enter hours to snooze.

Does any one knows if this bug have been fixed?.
I have Sunbird 0.2 Just downloaded a few days ago.
Thanks a lot
joejac

Updated

12 years ago
QA Contact: colint → sunbird
Reassigning all automatically assigned bugs from Mostafa to nobody@m.o

Bugspam filter: TorontoMostafaMove
Assignee: mostafah → nobody
jminta:
Should this be closed since we landed the new alarm snooze stuff?

Comment 14

11 years ago
(In reply to comment #13)
Yeah, I took special care to avoid this bug when re-writing the alarm code.

Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.