Closed Bug 1736967 Opened 1 month ago Closed 1 month ago

Perma toolchain cab error: failed to parse manifest at `/builds/worker/.cargo/registry/src/github.com-1ecc6299db9ec823/object-0.27.0/Cargo.toml

Categories

(Firefox Build System :: Toolchains, defect)

defect

Tracking

(firefox-esr78 unaffected, firefox-esr91 unaffected, firefox93 unaffected, firefox94 unaffected, firefox95 fixed)

RESOLVED FIXED
95 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox93 --- unaffected
firefox94 --- unaffected
firefox95 --- fixed

People

(Reporter: imoraru, Assigned: glandium)

Details

Attachments

(1 file)

The fail summary in treeherder is empty
Failure log

[fetches 2021-10-21T03:42:38.297Z] finished fetching artifacts
[task 2021-10-21T03:42:38.298Z] executing ['workspace/build/src/taskcluster/scripts/misc/build-makecab.sh']in /builds/worker
[task 2021-10-21T03:42:38.299Z] 
[task 2021-10-21T03:42:38.299Z] export PATH="$MOZ_FETCHES_DIR/rustc/bin:$PATH"
[task 2021-10-21T03:42:38.299Z] + export PATH=/builds/worker/fetches/rustc/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
[task 2021-10-21T03:42:38.299Z] + PATH=/builds/worker/fetches/rustc/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
[task 2021-10-21T03:42:38.299Z] 
[task 2021-10-21T03:42:38.299Z] cd $MOZ_FETCHES_DIR/rust-makecab
[task 2021-10-21T03:42:38.299Z] + cd /builds/worker/fetches/rust-makecab
[task 2021-10-21T03:42:38.299Z] 
[task 2021-10-21T03:42:38.299Z] cargo build --verbose --release
[task 2021-10-21T03:42:38.300Z] + cargo build --verbose --release
[task 2021-10-21T03:42:38.336Z]     Updating crates.io index
[task 2021-10-21T03:42:58.382Z]     Updating git repository `https://github.com/luser/flate2-rs/`
[task 2021-10-21T03:42:58.784Z]  Downloading crates ...
[task 2021-10-21T03:42:58.973Z]   Downloaded ansi_term v0.11.0
[task 2021-10-21T03:42:58.975Z]   Downloaded strsim v0.8.0
[task 2021-10-21T03:42:58.979Z]   Downloaded autocfg v1.0.1
[task 2021-10-21T03:42:58.981Z]   Downloaded adler v1.0.2
[task 2021-10-21T03:42:58.989Z]   Downloaded clap v2.33.3
[task 2021-10-21T03:42:59.012Z]   Downloaded time v0.1.44
[task 2021-10-21T03:42:59.014Z]   Downloaded cfg-if v1.0.0
[task 2021-10-21T03:42:59.016Z]   Downloaded vec_map v0.8.2
[task 2021-10-21T03:42:59.017Z]   Downloaded unicode-width v0.1.9
[task 2021-10-21T03:42:59.019Z]   Downloaded cfg-if v0.1.10
[task 2021-10-21T03:42:59.020Z]   Downloaded num v0.1.42
[task 2021-10-21T03:42:59.022Z]   Downloaded error-chain v0.7.2
[task 2021-10-21T03:42:59.025Z]   Downloaded cc v1.0.71
[task 2021-10-21T03:42:59.029Z]   Downloaded object v0.27.0
[task 2021-10-21T03:42:59.046Z] error: failed to parse manifest at `/builds/worker/.cargo/registry/src/github.com-1ecc6299db9ec823/object-0.27.0/Cargo.toml`
[task 2021-10-21T03:42:59.046Z] 
[task 2021-10-21T03:42:59.046Z] Caused by:
[task 2021-10-21T03:42:59.046Z]   feature `resolver` is required
[task 2021-10-21T03:42:59.046Z] 
[task 2021-10-21T03:42:59.046Z]   this Cargo does not support nightly features, but if you
[task 2021-10-21T03:42:59.046Z]   switch to nightly channel you can add
[task 2021-10-21T03:42:59.046Z]   `cargo-features = ["resolver"]` to enable this feature
[taskcluster 2021-10-21 03:42:59.467Z] === Task Finished ===
[taskcluster 2021-10-21 03:42:59.596Z] Artifact "public/build" not found at "/builds/worker/artifacts/"
[taskcluster 2021-10-21 03:42:59.656Z] Unsuccessful task run with exit code: 101 completed in 151.624 seconds

Mike, could you please have a look over these failures? Thank you.

Flags: needinfo?(mh+mozilla)

The only non-github CI change is the addition of default-features = false to the error-chain dependency, which removes the need for e.g.
the object crate.

Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/54672b7d3f45
Update makecab to trunk. a=toolchain-fix
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch
Flags: needinfo?(mh+mozilla)
You need to log in before you can comment on or make changes to this bug.