Allow for a user-specified location for profile data

VERIFIED DUPLICATE of bug 55309

Status

VERIFIED DUPLICATE of bug 55309
16 years ago
3 years ago

People

(Reporter: ovvldc, Assigned: ccarlen)

Tracking

({l12y})

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; nl-NL; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; nl-NL; rv:1.1) Gecko/20020826

Currently, the location of the profile data is hardcoded (see also bug 170061).
This is unfortunate because I would like to use Mozilla on different machines
but have the profile data on a single, shared, network drive or on a different
drive for a clear separation of data and program files.

Two options come to mind:

1. Let me specify a folder where all of the profiles are located, each with
their own subfolders, etc. for instance //HAL9000/Shared/Program data/Mozilla
profiles/

2. Let me specify a location for each profile. For instance
//HAL9000/Shared/Program data/Mozilla profiles/user1. This is the way Netscape
4.x worked.

I assume a registry key would be the way to go on Windows.

Reproducible: Always

Steps to Reproduce:
Not a reproduction issue, but an architecture problem.
(Reporter)

Comment 1

16 years ago
Added keywords
Keywords: 4xp, l12y
(Assignee)

Comment 2

16 years ago
When you create a profile with the Profile wizard, you can choose any location
you want for the profile - even a network drive *if* that drive has already been
mounted. What's missing here?
(Reporter)

Comment 3

16 years ago
I must have missed that because I tend to convert older profiles. These seem to
just get placed in the default location. I suppose a 'move' option in the
profile manager would fix that. Or an extra step in the conversion dialog that
asks where the converted profiles should go.

I trust that if you specify a location that already has profile data, it just
uses the existing stuff.

Sorry that I didn't investigate fully before filing the bug.

 Oscar

Comment 4

16 years ago
this looks like a duplicate of bug 55309

*** This bug has been marked as a duplicate of 55309 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified as a dupe of bug 55309
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.