Closed Bug 1737108 Opened 3 months ago Closed 2 months ago

Differentiate distribution IDs in MSIX packages intended for the Microsoft Store

Categories

(Firefox :: Installer, enhancement, P3)

enhancement

Tracking

()

VERIFIED FIXED
96 Branch
Tracking Status
firefox95 --- verified
firefox96 --- verified

People

(Reporter: nalexander, Assigned: bhearsum)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fidedi-tikka])

Attachments

(2 files, 1 obsolete file)

Right now, we have no way to distinguish installs from Mozilla-signed MSIX packages and installs from Microsoft-signed MSIX packages distributed by the Microsoft Store. This ticket tracks differentiating the distribution IDs.

Another way to achieve a similar result is to capture the package (family) name in Telemetry as follow-up to Bug 1709892.

Blocks: msix-packaging
No longer blocks: 1728471
Depends on: 1728471
No longer blocks: msix-packaging
Severity: -- → S3
Priority: -- → P3
Whiteboard: [fidedi-tikka]

We have some questions about the existing telemetry from Bug 1709892, so I'm leaning towards doing this by including the app package name and publisher (or family name) in telemetry directly. This is more robust than reporting the distribution ID. When I try this, I will only include app package data if it's likely Mozilla produced the packages. The allow-list will be that the publisher is "Mozilla" or "MozillaCorporation", I think.

Assignee: nobody → bhearsum

Comment on attachment 9249827 [details]
WIP: Bug 1697875 - WIP on Part 2: Annotate crash reports with Windows app package name and publisher. r?gsvelto

Revision D130188 was moved to bug 1738375. Setting attachment 9249827 [details] to obsolete.

Attachment #9249827 - Attachment is obsolete: true

This patch also removes the existing hasWinPackageId, because PackageFamilyName is essentially a richer version of the same thing (empty string is the same as !hasWinPackageId, and any non-empty string is the opposite, except we can distinguish between different packages).

Depends on D131520

Chris, I was about to file a data request for this, but it's actually the exact same piece of data that I filed one for in https://bugzilla.mozilla.org/show_bug.cgi?id=1738375, except we'll now be sending it through Telemetry in addition to Crash Stats. Does that need a separate request, or does the existing one carry over? (In retrospect, I probably should've included information about both bugs in the original request...).

Flags: needinfo?(chutten)

The request should cover both, just put a comment over in bug 1738375 so it's clear to anyone hitting it in future.

Flags: needinfo?(chutten)
Attachment #9251410 - Attachment description: WIP: Bug 1737108: Part 1: Expose MSIX PackageFamilyName in nsSystemInfo. r?mhowell! → Bug 1737108: Part 1: Expose MSIX PackageFamilyName in nsSystemInfo. r?mhowell!
Attachment #9251411 - Attachment description: WIP: Bug 1737108: Part 2: Differentiate MSIX packages intended for the Microsoft Store and others in Telemetry. r?mhowell!,chutten! → Bug 1737108: Part 2: Differentiate MSIX packages intended for the Microsoft Store and others in Telemetry. r?mhowell!,chutten!
Pushed by bhearsum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2e3dd3db672
Part 1: Expose MSIX PackageFamilyName in nsSystemInfo. r=mhowell
https://hg.mozilla.org/integration/autoland/rev/03d84f4e39a3
Part 2: Differentiate MSIX packages intended for the Microsoft Store and others in Telemetry. r=mhowell,chutten

Comment on attachment 9251410 [details]
WIP: Bug 1737108: Part 1: Expose MSIX PackageFamilyName in nsSystemInfo. r?mhowell!

Beta/Release Uplift Approval Request

  • User impact if declined: No direct user impact. The sooner we have this, the sooner we can analyze telemetry from MSIX installations in more depth.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed: no
Attachment #9251410 - Attachment description: Bug 1737108: Part 1: Expose MSIX PackageFamilyName in nsSystemInfo. r?mhowell! → WIP: Bug 1737108: Part 1: Expose MSIX PackageFamilyName in nsSystemInfo. r?mhowell!
Attachment #9251410 - Flags: approval-mozilla-beta?
Attachment #9251411 - Flags: approval-mozilla-beta?
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Hey Ben! Is there anything testable here? If so, could you provide some steps in order to verify this? Thank you!

Flags: needinfo?(bhearsum)

Comment on attachment 9251410 [details]
WIP: Bug 1737108: Part 1: Expose MSIX PackageFamilyName in nsSystemInfo. r?mhowell!

Approved for landing on the beta branch before RC, thanks.

Attachment #9251410 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9251411 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

(In reply to Catalin Sasca, QA [:csasca] from comment #11)

Hey Ben! Is there anything testable here? If so, could you provide some steps in order to verify this? Thank you!

Yes, the new value ("winPackageFamilyName") should show up in the "Environment" section of about:telemetry

Flags: needinfo?(bhearsum)

Thank you!

Verified on Windows 10x64 and Windows 11x64 that the "winPackageFamilyName" value is displayed inside about:telemetry#environment-data-tab using Firefox MSIX 96.0a1 (20211126050650) and 95.0b13 (20211126095952) from treehereder.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.