following links that use javascript to compute the next page often doesn't work

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Keith Morgan, Assigned: rogerl (gone))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

I've noticed this on at least one other site - clicking on a link to a local
page that uses javascript to determine which page to go to next results in no
action, no message.  Same page used with IE6 works fine.

Reproducible: Always

Steps to Reproduce:
1. Go to store.knifecenter.com, order an item
2. When presented with the 'checkout now or continue shopping' link, click on
the 'continue shopping' link.


Actual Results:  
Nothing - the browser never follows the link.  No error message, etc.

Expected Results:  
Bring up page showing shopping cart contents and a search textbox to continue
searching for more products.

Comment 1

16 years ago
Reporter: The Javascript works (perhaps you have Javascript disabled) . The
problem might also be, that you work with multipli windows on this site, because
it uses parent.history.go(-3). So there have to be already been 3 pages been
visited in this window, that this works.
Resolving Worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 2

16 years ago
Verified Worksforme with Mozilla trunk binary 20020930xx on WinNT.

Frank's analysis is correct: if you bring up IE6 from scratch and
go to the site and click on the 'continue shopping' link, nothing
happens, either. Same with Mozilla.

In either IE6 or Mozilla, you have to have visited at least three
sites before clicking on this link, because the "Continue Shopping"
link is coded to go back 3 sites in browser-history:

 <a href="javascript:parent.history.go(-3)">CONTINUE SHOPPING</a>

Why the site coded this is beyond me; it makes no sense at all.
But the behavior here is due to the site, not Mozilla.

If you HAVE visited at least three other sites first, and DO have
JavaScript enabled, and the link still doesn't work, please reopen
this bug. In such a case, please report if there are any errors in
Mozilla's  Tools > Web Development > JavaScript Console
Be sure to clear it of any previous errors first.

Thanks -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.