"Open Link in New Tab" should open new tab without going to that new tab, should not change focus from tab that link was opened from

CLOSED WORKSFORME

Status

SeaMonkey
Tabbed Browser
CLOSED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Brad Epperson, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1) Gecko/20020826

Every time a link is opened as a new tab (whether it be from the context menu or
middle-clicking with the mouse) opens the link in a new tab that is now on top
of all the other tabs (or in front of them or has focus, whichever terming is
correct).  On pages such as news sites where many links are of interest, it is
frustrating to have to go back to the main page after every link is opened in a
new tab.  Not only does it consume time, it is confusing, especially if you have
so many tabs open that the only thing showing in the title for the tabs is the
Favicon, and the Favicons are all the same because it's from the same site.

Sorry if this is a duplicate, this is the first time I've submitted a bug report
and I wasn't able to find this anywhere.

The problem I'm experiencing may actually be an intended result, but it is
frustrating and taints the usability of Mozilla. The "Phoenix" project seems to
have taken this into consideration in their builds (and it may simply be the
case that this issue has been addressed in the Moz 1.2 alpha and beta builds/trunk).

Reproducible: Always

Steps to Reproduce:
1. Go to a website with several links
2. Open each link a a new tab
3. Endure the hassle

Actual Results:  
Every time a link is opened in a new tab, the focus shifts to that new tab and I
have to sort through the other tabs, or "guess" which tab I was on before I
opened the new one.

Expected Results:  
The link should have opened in a new tab, with the focus remaining on the tab or
page that the link was opened from. You then have the choice/option of opening
more links from that page without having to sort through all your tabs and click
back on that original tab.

Comment 1

16 years ago
It's already there : 
Preferences -> Navigator -> Tabbed Browsing -> Load links in background.

Or do a ctrl-shift-click instead of a ctrl-click (or shift-middle-click ?) if
you want it for a single page only. The shift key even worsk for the context menu.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

16 years ago
Ah, so it is.  I didn't understand the meaning of "Open Links in Background." 
To me (maybe others) it was reading "Load links in the background (from each
page you visit) so that they're already downloaded for viewing when/if you
choose to follow those links."

Guess I'm not as smart as everyone gives me credit for  :-p

Should've tried it first.  Hope no one else is as dense as me in this regard! =)

Thanks!
Status: RESOLVED → CLOSED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.