Closed Bug 1737544 Opened 3 months ago Closed 2 months ago

Using Save As from the Context menu when saving a viewed pdf saves as .eml

Categories

(Thunderbird :: General, defect)

Thunderbird 91
Desktop
All
defect

Tracking

(thunderbird_esr91+ fixed, thunderbird94 wontfix, thunderbird95+ verified)

VERIFIED FIXED
96 Branch
Tracking Status
thunderbird_esr91 + fixed
thunderbird94 --- wontfix
thunderbird95 + verified

People

(Reporter: bugzilla, Assigned: nicolai)

Details

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:93.0) Gecko/20100101 Firefox/93.0

Steps to reproduce:

If you right click on a .pdf in the attachments pane of an email and select "Save As...", it correctly offers to save it as a .pdf file. However, if you double click on the .pdf file to view it in a new tab, and in that tab right click and select "Save As...", it incorrectly offers to save the .pdf as a .eml file.

Expected results:

Save as on the view .pdf file tab should save the file as a .pdf file.

I think the idea is to use the Download icon to the right of the Print icon in the Actions bar.

If I use your method, it does want to save as the email the PDF is attached to, and does just that.

If I try using File > Save As from the Menu bar, the choices are disabled.

So the bug as I see it is "Save As" isn't disabled in the context menu when using it to save a PDF being viewed.

Saving the email that the .pdf is attached doesn't really make sense. This tab is viewing the .pdf file, not the email, and any actions in this tab should be for the .pdf file itself. The email might have already been closed, even deleted.

I agree that saving the email doesn't make sense, and the user should use the Download icon to the right of the Print icon in the PDF Viewer.

There is no Save As context menu item If you open a PDF file in the browser version of PDF Viewer.

The download button behaves correctly. I hadn't noticed it until you told me about it. Thank you.

There is a "Save as..." if you right click in the PDF viewer within Thunderbird, and this is behaving incorrectly. It's this option that this bug report is regarding.

So the "Save As..." in the Context Menu should be disabled without breaking it for email messages.

Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → Desktop
Summary: Saving a viewed pdf saves as .eml → Using Save As from the Context menu when saving a viewed pdf saves as .eml

https://searchfox.org/comm-central/rev/5e94c611d13ff79f35b34f91c13af7064a927d58/mail/base/content/specialTabs.js#919
Could check if url has type=application/pdf.
If it has, we should use a differnt context menu. Like aboutPagesContext

Assignee: nobody → mkmelin+mozilla
Assignee: mkmelin+mozilla → nicolai
Status: NEW → ASSIGNED
Attachment #9249239 - Attachment is obsolete: true
Target Milestone: --- → 96 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/4e68656f3180
Change Context Menu for PDFs in Tabs to aboutPagesContext. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED

Comment on attachment 9249423 [details]
Bug 1737544 - Change Context Menu for PDFs in Tabs to aboutPagesContext. r=mkmelin

[Approval Request Comment]
User impact if declined: Saving PDF may cause confusion
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): Safe fix

Attachment #9249423 - Flags: approval-comm-esr91?
Attachment #9249423 - Flags: approval-comm-beta?

Comment on attachment 9249423 [details]
Bug 1737544 - Change Context Menu for PDFs in Tabs to aboutPagesContext. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9249423 - Flags: approval-comm-beta? → approval-comm-beta+

Using "Save As" from the attachment pane works for me using Thunderbird 95.0b3 on Windows 10.

Status: RESOLVED → VERIFIED

Comment on attachment 9249423 [details]
Bug 1737544 - Change Context Menu for PDFs in Tabs to aboutPagesContext. r=mkmelin

[Triage Comment]
Approved for esr91

Thanks Walt for verifying

Attachment #9249423 - Flags: approval-comm-esr91? → approval-comm-esr91+

Sorry, I think I misunderstood this bug report and wrongly verified 95.0b3.

When testing 91.3.2 on Windows 10 with the PDF attachment open in a tab, I only see these 3 items in the context menu when right-clicking in the tabs body.

  • Copy
  • Paste
  • Select All
    Same with 95.0b3 on Windows and Linux.

Checking with 91.3.1 the context menu in the tabs body starts with "Select All" and ends with "Print".
Using the "Save As" in that menu saved the attachment as an email.
Using "Save As" from the Attachment Pane saves it as the PDF file.

I would use the Download button in the tab if I opened the attachment in a tab.

You need to log in before you can comment on or make changes to this bug.