address auto-completion doesn't always work - inconsistent behaviour after erasing a suggested address

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
7 years ago

People

(Reporter: david, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

In certain circumstances, e-mail address completion fails to find an e-mail
address that does match.  I've outlined step by step how this can be reproduced.

Reproducible: Always

Steps to Reproduce:
1.Open address book
2.Add an entry:  first name="Wooly", last name="Sheep", e-mail=wooly@wooly.com
3.Add an entry:  first name="Angry", last name="Antelope", e-mail=ant@angry.com
4.Close address book
5.Compose an e-mail
6.Click in the "To" field and type "Wooly" - watch it correctly come up with:
Wooly Sheep <wooly@wooly.com>
7.Press the home key
8.Hold down shift and press the end key so that the previous entry is
highlighted and then release the shift key
9.Now quickly type "Angry" and watch it come up with something other than Angry
Antelope - for me it comes up with Angry@pastornet.net.au (my e-mail address is
in that domain).
I BELIVE THIS BEHAVIOUR TO BE WRONG
10.Now if you immediately repeat steps 7, 8 and 9 again, you get the correct
behaviour.
Actual Results:  
You get inconsistent behaviour - sometimes it does completion correctly and
other times you end up with something in your own e-mail domain.

Expected Results:  
I would expect completion to work every time, not just sometimes.

Comment 1

16 years ago
I was able to reproduce the symptoms, 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030516

 -- but not reliably; sometimes it took two or three deletions before the 
problem exhibited itself.

Updating summary for a little more clarity.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: E-mail address completion doesn't always work - inconsistent behaviour if you erase an address and then expect completion to work again → address auto-completion doesn't always work - inconsistent behaviour after erasing a suggested address
(Reporter)

Comment 2

15 years ago
Still present in 1.8a2.
Product: MailNews → Core

Comment 3

14 years ago
I find with 1.8b1 that autocompletion doesn't work AT ALL if adding an
additional address under the one being replied to. This may well be a different
bug, however. Will submit if so advised. 

Compose a new mail works no problem.

Comment 4

14 years ago
(In reply to comment #3)
> I find with 1.8b1 that autocompletion doesn't work AT ALL if adding an
> additional address under the one being replied to. This may well be a
> different bug, however. Will submit if so advised. 
> 
> Compose a new mail works no problem.

First: I don't know why you'd say "may well be" a different bug -- it's quite 
obvious to me that it most definitely is a different bug.

Second: That problem has already been fixed -- bug 282645 -- which is why 
testers are asked to try a current build before reporting bugs at all.

Updated

10 years ago
Assignee: ducarroz → nobody
QA Contact: esther → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 5

9 years ago
I can't reproduce.
Is there a missing step?
Can anyone else reproduce?
Whiteboard: closeme 2009-10-21
(Reporter)

Comment 6

9 years ago
I just tested with 2.0.0.23 and it still fails.  Reproducing this seems to depend on the speed of how fast you type.  But an alternative way to reproduce is as follows, using paste (which normally does complete, but in this circumstance, the same as typing quickly, doesn't).

Steps to Reproduce:
1.Open address book
2.Add an entry:  first name="Wooly", last name="Sheep", e-mail=wooly@wooly.com
3.Add an entry:  first name="Angry", last name="Antelope", e-mail=ant@angry.com
4.Close address book
5.Compose an e-mail
5a.  Type "Angry" or "Angry Antelope" in the subject line (no quotes)
5b.  Highlight the contents of the subject line and then copy it
6.Click in the "To" field and type "Wooly" - watch it correctly come up with:
Wooly Sheep <wooly@wooly.com>
7.Press the home key
8.Hold down shift and press the end key so that the previous entry is
highlighted and then release the shift key
9.Now paste with CTRL-V (or very quickly type "Angry" or "Angry Antelope") and watch it fail matching
Whiteboard: closeme 2009-10-21

Comment 7

9 years ago
thanks for retesting. however, v3.0 is where the action is, because it's substantially changed.  If someone who sees this can test v3 that would be great.
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
backup your profile before using

Comment 8

7 years ago
closing WFM based comment 5.
If you still see the problem using version 3. or 5, the pplease update the bug.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.