Mozilla frequently ignores Mac OS menu command keys (e.g. New, Copy, Cut, Paste)

RESOLVED DUPLICATE of bug 174610

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 174610
16 years ago
14 years ago

People

(Reporter: Vicki Brown, Assigned: asa)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0; hi, Mom) Gecko/20020604
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0; hi, Mom) Gecko/20020604

I launch Mozilla and enter cmd-N for a new window; no new window appears. I
select "New...Navigator Window" from the menu (noting that it claims cmd-N is an
equivalent and get a new window.

I select text and enter cmd-C to copy, but pasting pastes something from a
previous copy. Selecting Copy from the menu works (and the manu item claims
cmd-C is an equivalent).

I select text and enter cmd-X to cut but the text is not cut...

This happens fairly regularly; somehow Mozilla is missing the cmd key signals
about half of the time or "better". I also have my trackball buttons set to send
the cmd-C and cmd-V signals; sometimes they work, sometimes they don't.

cmd-keys and the trackball work pretty consistently as expected in other apps.

Reproducible: Sometimes

Steps to Reproduce:
1.read details; they give all the pertinent info
2.
3.



Expected Results:  
I expect the command key equivalents to work every time.

Comment 1

16 years ago
Vicki, Mozilla 1.0 is rather old for bug reporting purposes. Please retest using
a more recent build.

Comment 2

16 years ago
Whoops, looks like you used Mozilla 1.0 on *Linux* to report this, but you
reported it about Mozilla on Mac OS X. What Mozilla build ID were you using on
Mac OS X?
(Reporter)

Comment 3

16 years ago
I used (and am using) Mozilla 1.1 on Mac OS X (specifically 10.2.1) to report
this. If Mozilla "saw" 1.0 or Linux... looks like a different bug in Mozilla
there! We have neither Mozilla 1.0 (nor linux) anywhere in our net.

Comment 4

16 years ago
Vicki, do you have a custom user agent string set for some reason? Can you
reproduce this problem using another Mozilla user profile?
(Reporter)

Comment 5

16 years ago
> do you have a custom user agent string set for some reason?
only for the "reason" that it was part of the sample user.prefs I downloaded from 
http://www.mozilla.org/unix/customizing.html#prefs
and this line blindsided me (I _did_ work through the prefs and remove things I
was sure I didn't need but I missed this one; personally, I don't think it
should have been there!)

I deleted the custom string but it still seems to be stuck somewhere. I'll come
back to this bug after I figure out how to keep it dead.
(Reporter)

Comment 6

16 years ago
I have removed the offending, unexpected and undesirable "custom user agent string"
and my About... now says, correctly:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020910

Mozilla still ignores my command key presses.

Comment 7

16 years ago
Did you test another Mozilla user profile?
(Reporter)

Comment 8

16 years ago
>Did you test another Mozilla user profile?

Creating another profile is difficult because the Moxzilla Profile Manager does
not work for me. However:

When I remove both my prefs.js and user.js file from my "Profile" folder, the
problem "goes away". I can't imagine what preference I have that would keep
something as intrinsic as command keys from working on Mac OS X... whatever it
is, it should NOT blockcommand key use. But I'll close this in favor of bug
174610 ; there is too much unnecessary commentary about "user agents in this
bug; that obscures the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 9

16 years ago
This isn't really "invalid". The problem is real.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 10

16 years ago
But the better report is bug 174610

*** This bug has been marked as a duplicate of 174610 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.