Status

()

Core
Layout: View Rendering
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Terry Valladon, Assigned: roc)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
using a div with an style of:
overflow: auto;-moz-opacity:0.4;
and an image as the pages background when it first loads the alpha blending
works fine until you scroll the div down, then the alpha blending messes up.

Also with the same code the scrollbar is "stickey" and "jerkey"... when you try
to drag it it locks to the mouse so even when you release the mouse button it
will continue to scroll when you move the mouse.

See my URL to see what I mean for both cases.

Other then that you guys have done a band up job so far. Never thought some of
the fancy things IE does would be working in moz this soon.

This was tested in win2k and FreeBSD (both with latest build of browser).

Thank you,
     Terry Valladon
http://www.sublinear.net/~slasherx/main.php seems to be a more useful url (esp.
if you have popup blocking on).

Over to something more like the right component.
Assignee: jst → roc+moz
Status: UNCONFIRMED → NEW
Component: DOM Style → Views
Ever confirmed: true
OS: other → All
QA Contact: ian → petersen

Comment 2

15 years ago
http://pixelkitty.net/ makes an excellent test-case for -moz-opacity slowing
down scrolling.
cached at http://othersdietrying.com/red_one/pixelkitty.net/
(Reporter)

Comment 3

15 years ago
alpha is working right in latest build but the scroll bar is still "sticky"
I don't see the "sticky scrollbar" problem.
(Reporter)

Comment 5

15 years ago
That too is fixed..

Thank you
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.