Closed Bug 1738793 Opened 11 months ago Closed 10 months ago

firefox_build/dist/system_wrappers/X11/extensions/XTest.h:3:15: fatal error: X11/extensions/XTest.h: No such file or directory

Categories

(Firefox Build System :: General, defect, P3)

Firefox 96
defect

Tracking

(firefox-esr91 unaffected, firefox94 unaffected, firefox95 unaffected, firefox96 fixed)

RESOLVED FIXED
96 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox94 --- unaffected
firefox95 --- unaffected
firefox96 --- fixed

People

(Reporter: herrtimson, Assigned: glandium)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

I downloaded latest nightly sources and compiled them

Actual results:

I got this error:

21:19.32 In file included from /usr/aarch64-unknown-linux-gnu/tmp/portage/www-client/firefox-96.0/work/firefox-96.0/third_party/libwebrtc/modules/desktop_capture/linux/shared_x_display.cc:14,
21:19.32                  from Unified_cpp_p_capture_generic_gn1.cpp:29:
21:19.32 /usr/aarch64-unknown-linux-gnu/tmp/portage/www-client/firefox-96.0/work/firefox_build/dist/system_wrappers/X11/extensions/XTest.h:3:15: fatal error: X11/extensions/XTest.h: No such file or directory
21:19.32     3 | #include_next <X11/extensions/XTest.h>
21:19.32       |               ^~~~~~~~~~~~~~~~~~~~~~~~

Expected results:

/usr/include/X11/extensions/XTest.h is part of the libXtst package, and I don't have it installed. Normaly this should be checked for in the configure scripts, and they are supposed to throw an error if the headers of libs are missing.

So, unless this is a false positive, please check for the package during configure.

I will attach the full build log (compressed)

Component: Untriaged → General
Product: Firefox → Firefox Build System
Flags: needinfo?(dminor)
Regressed by: 1654112
Has Regression Range: --- → yes
Flags: needinfo?(dminor) → needinfo?(na-g)

Set release status flags based on info from the regressing bug 1654112

Is libXtst something we'll need to add to the Linux system requirements for Firefox going forward too?

Ryan, yes, it looks like it. Digging into the new libwebrtc code, libXtst is being used for desktop capture. https://searchfox.org/mozilla-central/rev/a12c2c2e59c92d8f969d8f3f290ab16919449c9d/third_party/libwebrtc/modules/desktop_capture/linux/shared_x_display.cc#14

Flags: needinfo?(na-g)

yes, this became appearent when new webrtc code was checked into the nightly branch.

Priority: -- → P3

Nico, this feels like a bug we don't want to ship with in its current state. Can you write the patch mentioned by comment 0 (erroring out during configure if libXtst isn't detected)?

Flags: needinfo?(na-g)
Assignee: nobody → mh+mozilla
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/e786bc831dc2
Check for libXtst during configure. r=firefox-build-system-reviewers,mhentges
Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch

Thanks for submitting the patch! I’ll return from PTO on 30/11 if anything else needs to be done.

Flags: needinfo?(na-g)
You need to log in before you can comment on or make changes to this bug.