User customizable user-agent

VERIFIED WONTFIX

Status

()

Core
Networking: HTTP
--
enhancement
VERIFIED WONTFIX
15 years ago
15 years ago

People

(Reporter: Andrei Boros, Assigned: Darin Fisher)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Request a prefs option (either UI or prefs.js - more likely) that can override 
the User-agent Mozilla sends in the HTTP headers. 

Some sites deny access or redirect when viewed with mozilla. I was able to view 
some of such sites by having a proxy that fakes my user agent, but I need 
administrative right on that proxy, which may not be the case for many users.

Other browser that I know it supports such an override with option : 
-useragent=Name
Web download software such a Getright, Teleport Pro can also send a custom 
user-agent.
(Assignee)

Comment 1

15 years ago
there is a project on mozdev.org which provides this feature.  this won't be
added to mozilla.  beware that UA spoofing can cause a lot of problems.  e.g.,
java plugin will crash if you spoof IE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

15 years ago
I believe you should have resolved this bug as DUPLICATE

(looking through mozdev.org and finding uabar sent me to similar bugreports I 
haven't found in my searches before this one. I was able to do a more in depth 
research this time (sorry for the initial spam))

Bugs that this might dupe :
#22995 cusomizable user_agent
They marked this WONTFIX, yet other related reports say otherwise. (probably due 
to the earlier stage of development)

#80658 [RFE] Site specific User-Agent
Also see comment #17
Resolution on this is definitely not wontfix

#154645 Faking to be a MSIE browser 
This dupes #80658

#140417 Need "Hall of Shame" feature to encourage uncooperative sites

#46029 [RFE] debug-only GUI for multiple User-Agent prefs like in Opera

#102042 [RFE]Separate the useragent used by http from the actual one seen by 
plug-ins
The Java issue invoked here for the WONTFIX resolution is described and 
atended to here. 

#101990 useragent per-site settings Tool

#83376 Crash when loading Java Plugin if UserAgent string as MSIE
This could be considered as a blocker for this bug.

Please reconsider.


(Assignee)

Comment 3

15 years ago
well, you tell me.  which of those bugs most closely matches your bug
description? :)
(Reporter)

Comment 4

15 years ago
Considering how I formulated the report, I think the proper dupe should be 
#46029 [RFE] debug-only GUI for multiple User-Agent prefs like in Opera

Though, after finding out more, I adhere to 
#80658 [RFE] Site specific User-Agent
(Assignee)

Comment 5

15 years ago
making this bug depend on the outcome of bug 80658 then.
Depends on: 80658

Comment 6

15 years ago
Verified.
Status: RESOLVED → VERIFIED
OS: Windows 95 → All
QA Contact: httpqa → junruh
Hardware: PC → All
*** Bug 203498 has been marked as a duplicate of this bug. ***
*** Bug 211099 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.