Button, not field, has focus in authentication dialog

VERIFIED WORKSFORME

Status

()

Firefox
General
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Jenn Drummond, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When I go to log in to a site that requires HTTP authentication, the dialog
named "Prompt" comes up with its focus on the "OK" button. In Mozilla, the focus
is in the username field, which is much more convenient if you don't habitually
save your passwords.
What version are you using ?

This is probably Bug# 172194 which occured just before milestone 0.2 and fixed
in 0.3

See
http://bonsai.mozilla.org/cvsquery.cgi?branch=HEAD&file=mozilla/xpfe/global/resources/content/commonDialog.js&date=month
for the history.

Also Bug# 172038, 172166, 172341, and possibly others (just learning bugzilla),
still marked new/open which are the same bug. 

Comment 2

16 years ago
works for me linux 10/19.  the http auth dialog has initial focus in the
username field.

Comment 3

16 years ago
jenn, I'm resolving this WFM since it looks like this was fixed.  

if you still see this behaviour in recent builds, reopen this bug. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 4

15 years ago
VERIFIED Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030714
Mozilla Firebird/0.6
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.