The default bug view has changed. See this FAQ.

Add Send Page (as Link) to File menu

VERIFIED FIXED in Firebird0.7

Status

()

Firefox
Menus
P1
enhancement
VERIFIED FIXED
15 years ago
11 years ago

People

(Reporter: Chris Schanck, Assigned: Scott MacGregor)

Tracking

unspecified
Firebird0.7
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021001 Phoenix/0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021001 Phoenix/0.2

While clearly Phoenix doesn't need Mail/News, a simple SMTP Send Page/Send Link
piece *is* needed. I sue this all the time, and it currently is the onl thing
preventing me from using Phoenix as my primary browser. Ideally, it would be
nice to have "Send Page/Link with ..." allowing you to pick from multiple SMTP
transports.

Reproducible: Always

Steps to Reproduce:
1. Pull doen File menu
2. Notice there is no Send Page
3.

Actual Results:  
No Send Page option

Expected Results:  
Send Page option

I really don't want to seem as if we should have Mail/News in Phoenix. But Send
Page, without going to an external program, is absolutely critical. Could it be
done easily as a XUL addin?

Comment 1

15 years ago
*** Bug 174199 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

15 years ago
Created attachment 104478 [details] [diff] [review]
Implement basic "Send Link" functionality via mailto:

This is kind of a cheesy way to do it, but this patch at least adds some basic
"Send Link" functionality to Phoenix without much effort.  

It uses the mailto: protocol handler, so I assume it could work on all
platforms.  And it can always be augmented once better
MAPI/Thunderbird/whatever support is available.

Updated

15 years ago
Target Milestone: --- → Phoenix0.6

Comment 3

15 years ago
Moving to Menus
Component: General → Menus

Comment 4

15 years ago
Comment on attachment 104478 [details] [diff] [review]
Implement basic "Send Link" functionality via mailto:

blake, is this something we want? if so, can you review it please?
Attachment #104478 - Flags: review?(blaker)

Comment 5

14 years ago
In my opinion, there should also be the possibility to add a toolbar button for
this. I just got a mail from a user of IE, asking if Phoenix could do this.
(Reporter)

Comment 6

14 years ago
I'd like to see this as a pull-down toolbar/menu option, (like the back bar)
with multiple SMTP choices. ON my laptop, I have as many as 5 different outgoing
mail servers, depending on where I am and what vpn is currently up. Thought for
food.

Comment 7

14 years ago
Now that Minotaur is active, this would be really nice.  There should be a way
to send a page or link via the default mail client.

Updated

14 years ago
Priority: -- → P1
Target Milestone: Phoenix0.6 → Phoenix0.7

Comment 8

14 years ago
Comment on attachment 104478 [details] [diff] [review]
Implement basic "Send Link" functionality via mailto:

I won't comment too much on the actual method of sending, although it seems
like the easiest way of doing it.

I'd prefer the menu item to be under Save in the File menu.  If we were to
mimic what IE does, it would be below the Print items as well.

Also, to be consistent with existing menu items, "context-sendthislink" should
be named "context-sendlink" and "context-sendlink" should be named
"context-sendpage".

Updated

14 years ago
Blocks: 164421

Updated

14 years ago
Target Milestone: Firebird0.7 → Firebird0.8

Comment 9

14 years ago
Taking QA Contact as designated owner of Firebird-Menus. Sorry for bugspam.
QA Contact: asa → bugzilla

Updated

14 years ago
Blocks: 214302

Comment 10

14 years ago
I just looked at the patch and I'm not sure setting the Subject to the URI is
the best solution.  It would be better to set the Subject to the page title and
the Body to the URI.

Comment 11

14 years ago
*** Bug 214794 has been marked as a duplicate of this bug. ***
see also bug #144828 for how shliang implemented this in the app suite, when the
user does a nav only install.

Comment 13

14 years ago
The relevant portion of that patch appears to be this:

+    function openExternalMailer(url) {
+      var extProtocolSvc =
Components.classes["@mozilla.org/uriloader/external-protocol-service;1"]
+                                    
.getService(Components.interfaces.nsIExternalProtocolService);
+      var ioService = Components.classes["@mozilla.org/network/io-service;1"]
+                                .getService(Components.interfaces.nsIIOService);
+      var mailto = url ? "mailto:?body="+url : "mailto:";
+      var uri = ioService.newURI(mailto, null, null);
+
+      extProtocolSvc.loadUrl(uri);
+    }

Comment 14

14 years ago
That's only for Send Link and is basically the same as the current patch (but
puts the URL in a different place).
(Assignee)

Comment 15

14 years ago
taking. I'll help drive this into firebird.
Assignee: blake → scott
(Assignee)

Comment 16

14 years ago
Created attachment 129389 [details] [diff] [review]
Send Page, Send Link and Send Image support

This patch adds:

1) A Send Page menu item to the File menu.

2) Send Page, Send Link and Send Image to the context menu. Send Link and Send
Image are only visible if you are on top of a link or an image respectively.

In all cases we generate a mailto url and kick the url out to the operating
system.

This will work on Mac, Windows and OS2.

Unix users have to wait for nsIExternalProtocolService::loadUrl to be
implemented
Attachment #104478 - Attachment is obsolete: true
Comment on attachment 129389 [details] [diff] [review]
Send Page, Send Link and Send Image support

r=ben@bengoodger.com
Attachment #129389 - Flags: review+
(Assignee)

Comment 18

14 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Target Milestone: Firebird0.8 → Firebird0.7

Comment 19

14 years ago
There is a major omission from this fix.  Send Page on the File menu does the IE
equivalent of Send->Link by E-mail.  Thus, we are still missing Send->Page by
E-mail, which is what Send Page should really do.  Perhaps the current menu item
should be changed to Send Page as Link.  (See bug 144484 for discussion)
Also, this line of the patch seems to be an error (the id should be
menu_sendPage to be consistent):
+                <menuitem id="menu_sendLink"  label="&sendPageCmd.label;" 
accesskey="&sendPageCmd.accesskey;"  command="Browser:SendLink"/>
Should I open up new bugs?

Comment 20

14 years ago
I just found another huge issue with the patch.  It doesn't pass the query
string to the e-mail client.  Again, do we want this reopened, or a new bug?
so mscott doesn't have to repeat this, he tells me:

"Send Link" is used to imply sending the link when you are hovering over a link
in the page and "Send Page" means send the link of the actual page.

Comment 22

14 years ago
Yes, that is obvious by looking at the patch.  However, the summary specifically
asked for Send Link in the File menu.  The only way that makes sense is if it is
interpreted as Send Page as Link, which would then imply that Send Page means
Send Page as Attachment, which is exactly what the cooresponding Mozilla (suite)
bugs refer to, and the two functions offered by IE.  In any case, perhaps I
should open new bugs since I have gotten no response here re comment 19 and
comment 20.

Comment 23

14 years ago
I definitely want both options - Send Page and Send Link (to current page) -
just like the full Mozilla browser has.  That's why I have a vote for this bug,
so I'm in agreement with comment <a
href=http://bugzilla.mozilla.org/show_bug.cgi?id=173954#c19>19</a>.

Comment 24

14 years ago
Created new bugs:
Bug 216168: Add Send Page (as Attachment) to File menu
Bug 216169: Inconsistent naming sendpage/sendlink
Bug 216170: Send Page (as Link) omits query string

Resolving this as verified.  Please move your votes to the new bug(s) of your
choice.

Status: RESOLVED → VERIFIED
Summary: Add Send Page/Send Link to File menu → Add Send Page (as Link) to File menu

Comment 25

14 years ago
I'm confused about this bug.  I just installed a 0903 build, and the Mozilla
Mail compose window that is opened is completely blank.  No URL or anything.

Updated

14 years ago
Attachment #104478 - Flags: review?(blake)

Comment 26

14 years ago
Same problem with 0.7.  The "Send Page" menu option opens a blank Mozilla Mail
window for me.  Any ideas why?  Presumably it's working for other people?

Comment 27

14 years ago
WFM Firebird 0.7  (in that it creates a new email with the URL as the body)
What mail client are you using Doug?
Perhaps try a new profile?

Comment 28

14 years ago
Darn.  Tried with a fresh profile, and still the same behaviour.  Mail client is
Mozilla Mail 1.5, but it also happened with 1.4.

Comment 29

14 years ago
Just tried from home and got different, also incorrect behaviour.  There it
opens a new instance of Mozilla Mail - not a new compose window.  Home is XP,
work is Win2K.  Both with same versions of Firebird and Mozilla.

Comment 30

14 years ago
FWIW - when I switched at home to Thunderbird as my default mail client, this
started working.  It still doesn't work (at work) with Mozilla Mail, though.

Updated

12 years ago
No longer blocks: 164421

Updated

12 years ago
Blocks: 158464

Updated

11 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.