Closed Bug 1739604 Opened 11 months ago Closed 11 months ago

The PIP is not set as "Always on top" by default in wayland

Categories

(Core :: Widget: Gtk, defect)

Desktop
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1621261
Tracking Status
firefox96 --- affected

People

(Reporter: danibodea, Unassigned)

References

(Blocks 2 open bugs)

Details

Note

  • When the user opens the browser with wayland window manager, loads a yourtube video and clicks the "Watch in Picture-in-Picture" button and moves another window over it, he will notice that the PIP is not set as "Always on top" by default.

Affected versions

  • Nightly v96.0a1

Affected platforms

  • Ubuntu 21 + wayland

Steps to reproduce

  1. Launch browser with wayland window manager:
    a. Go into the nightly folder.
    b. Right-click and "Open in Terminal".
    c. MOZ_ENABLE_WAYLAND=1
    d. ./firefox
  2. Load https://www.youtube.com/watch?v=SXr8Rb97nIk
  3. Click the "Watch in Picture-in-Picture" button.
  4. Move any other window over it.

Expected result

  • The PIP video is displayed on top of any other window.

Actual result

  • The PIP video is left in the background of other windows.

Regression range

  • unknown.

Additional notes

  • This issue occurs with "wayland" Window Protocol and not with "xwayland".

Duplicate of bug 1621261

Applications can't make themselves "always on top" on Wayland. Only the user can do it manually by right click.

Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: wayland-pip
You need to log in before you can comment on or make changes to this bug.