install error -204 if temp dir (Win login) contains non-ascii chars

RESOLVED DUPLICATE of bug 167515

Status

--
major
RESOLVED DUPLICATE of bug 167515
16 years ago
9 months ago

People

(Reporter: ruben, Assigned: dveditz)

Tracking

({helpwanted})

Trunk
x86
Windows XP
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [see comment 3])

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.0.3705)
Build Identifier: http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.2a/mozilla-win32-1.2a-installer.exe

when trying to install, i get an error box saying "Mozilla XPCOM: -204 
NO_INSTALL_SCRIPT"
happens with net installer and full installer, also happens with all possible 
install configurations

Reproducible: Always

Steps to Reproduce:
1.start mozilla-win32-1.2a-installer.exe
2.click on next at every screen
3.get error

Actual Results:  
i got the error and the installer quit

Expected Results:  
installed itself

my account name includes the letter "ö"
XP Pro SP1 (US)
Athlon Thunderbird 1100
ASUS A7V
Geforce 4 Ti4600

*** This bug has been marked as a duplicate of 167515 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
I might add that I have the same problem with the cheats database DLH98 
(www.dlh.net) - it tries to write to the Temp folder, but also got problems 
with some letters. Compatibility didn't make it work, so I just changed the 
Temp folders.
Severity: blocker → major
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

16 years ago
Fix needed: support for letters such as ö,ä,ü in installer
Temporary workaround: enforce Temp folders that don't contain these letters
Summary: cannot install, xpcom error → install error -204 if temp dir (Win login) contains non-ascii chars

Updated

16 years ago
Keywords: helpwanted
Whiteboard: [see comment 3]

Comment 4

15 years ago
dupe, as said before, and that one is fixed. If this is still broken on a recent
nightly, then please, file a new bug and mark it as a regression.


*** This bug has been marked as a duplicate of 167515 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.