CNN crashes but ONLY when pop-up blocking is turned on [@ GetPortHiliteColor]

RESOLVED DUPLICATE of bug 150887

Status

--
critical
RESOLVED DUPLICATE of bug 150887
16 years ago
16 years ago

People

(Reporter: stannehi, Assigned: saari)

Tracking

({crash})

Details

(crash signature, URL)

(Reporter)

Description

16 years ago
This is to clarify a recent post I saw about the CNN page crashing. It only
crashes with pop up blocking turned on (the main CNN page serves a pop up). Turn
it off and there is no problem.

Comment 1

16 years ago
Could you provide a stack trace ?

Comment 2

16 years ago
Also, Stuart, what build ID are you reporting this bug against?
Keywords: crash, stackwanted
Summary: CNN crashes but ONLY when pop up blocking is turned on → CNN crashes but ONLY when pop-up blocking is turned on
(Reporter)

Comment 3

16 years ago
In answer to the previous 2 requests:

Build ID: 2002100904

This is from Navigator.crash.log:

Date/Time:  2002-10-09 16:59:19 -0400
OS Version: 10.2.1 (Build 6D52)
Host:       ----------

Command:    Navigator
PID:        474

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0x7c00400a

Thread 0 Crashed:
 #0   0x91a73f5c in GetPortHiliteColor
 #1   0x003c5da8 in nsLookAndFeel::NativeGetColor(nsILookAndFeel::nsColorID,
unsigned&)
 #2   0x0065f290 in nsXPLookAndFeel::GetColor(nsILookAndFeel::nsColorID, unsigned&)
 #3   0x0026f6cc in SetColor(nsCSSValue const&, unsigned, nsIPresContext*,
unsigned&, int&)
 #4   0x002748f4 in nsRuleNode::ComputeBackgroundData(nsStyleStruct*,
nsCSSStruct const&, nsIStyleContext*, nsRuleNode*, nsRuleN
ode::RuleDetail const&, int)
 #5   0x0027146c in nsRuleNode::WalkRuleTree(nsStyleStructID, nsIStyleContext*,
nsRuleData*, nsCSSStruct*, int)
 #6   0x002707f8 in nsRuleNode::GetBackgroundData(nsIStyleContext*, int)
 #7   0x00278478 in nsRuleNode::GetStyleData(nsStyleStructID, nsIStyleContext*, int)
 #8   0x004771b4 in nsStyleContext::GetStyleData(nsStyleStructID)
 #9   0x007c5208 in FindElementBackground(nsIPresContext*, nsIFrame*,
nsStyleBackground const**)
 #10  0x00616210 in nsCSSRendering::FindBackground(nsIPresContext*, nsIFrame*,
nsStyleBackground const**, int*)
 #11  0x0061ea5c in nsHTMLContainerFrame::CreateViewForFrame(nsIPresContext*,
nsIFrame*, nsIStyleContext*, nsIFrame*, int)
 #12  0x00309a24 in nsCSSFrameConstructor::ConstructBlock(nsIPresShell*,
nsIPresContext*, nsFrameConstructorState&, nsStyleDispl
ay const*, nsIContent*, nsIFrame*, nsIStyleContext*, nsIFrame*)
 #13  0x002fd70c in
nsCSSFrameConstructor::ConstructFrameByDisplayType(nsIPresShell*,
nsIPresContext*, nsFrameConstructorState&,
 nsStyleDisplay const*, nsIContent*, nsIFrame*, nsIStyleContext*, nsFrameItems&)
 #14  0x002fe688 in nsCSSFrameConstructor::ConstructFrameInternal(nsIPresShell*,
nsIPresContext*, nsFrameConstructorState&, nsIC
ontent*, nsIFrame*, nsIAtom*, int, nsIStyleContext*, nsFrameItems&, int)
 #15  0x002fe240 in nsCSSFrameConstructor::ConstructFrame(nsIPresShell*,
nsIPresContext*, nsFrameConstructorState&, nsIContent*,
 nsIFrame*, nsFrameItems&)
 #16  0x00307db4 in nsCSSFrameConstructor::ProcessChildren(nsIPresShell*,
nsIPresContext*, nsFrameConstructorState&, nsIContent*
, nsIFrame*, int, nsFrameItems&, int, nsTableCreator*)
 #17  0x002f9548 in nsCSSFrameConstructor::InitializeSelectFrame(nsIPresShell*,
nsIPresContext*, nsFrameConstructorState&, nsIFr
ame*, nsIFrame*, nsIContent*, nsIFrame*, nsIStyleContext*, int, int, int)

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 150887 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: stackwanted
Resolution: --- → DUPLICATE
Summary: CNN crashes but ONLY when pop-up blocking is turned on → CNN crashes but ONLY when pop-up blocking is turned on [@ GetPortHiliteColor]
Crash Signature: [@ GetPortHiliteColor]
You need to log in before you can comment on or make changes to this bug.