Closed Bug 1740442 Opened 28 days ago Closed 22 days ago

[DE][amazon.de] The Cardholder Name is not recognised by Credit Card capture not autofill

Categories

(Toolkit :: Form Autofill, defect, P1)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
96 Branch
Tracking Status
firefox94 --- disabled
firefox95 --- disabled
firefox96 --- disabled

People

(Reporter: tbabos, Assigned: tgiles)

References

(Blocks 1 open bug, )

Details

Attachments

(2 files)

Affected Versions:
All latest Firefox versions. Reproducible back to Fx91 as well

Tested on:
MacOS 10.15

Preconditions:
browser.search.region DE
extensions.formautofill.supportedCountries DE
download latest Firefox Nightly with region locale (switch extensions.formautofill.available to "on" for testing non-Nightly builds)

Steps to reproduce:

  1. Reach the payment form on amazon.de (make sure you have at least 1 CC saved)
    2.1. Click on the Cardholder Name dropdown
    2.2. Fill in data in the Cardholder Name field and submit the form

Expected Results:
2.1. The Credit Card dropdown should be displayed upon clicking on the Cardholder Name field.
2.2. The doorhanger should also capture the Cardholder Name field data

Actual Results:
The Cardholder Name is not recognized by Credit Card capture not autofill

Notes:
Reproducible on Chrome: No
Also not reproducible on other tested Amazon locales (US, UK, FR, CA). This is specific for DE locale Amazon site.

Priority: -- → P1

This is probably a missing heuristic in https://searchfox.org/mozilla-central/source/toolkit/components/formautofill/content/heuristicsRegexp.js from my first hunch, since we're working as expected on the English site but not the German site.

Assignee: nobody → tgiles
Status: NEW → ASSIGNED
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/42e02578ba7c
Fix missing cc-name for DE heuristics. r=sgalich
Status: ASSIGNED → RESOLVED
Closed: 22 days ago
Resolution: --- → FIXED
Target Milestone: --- → 96 Branch
Blocks: 1741719

Verified-fixed on the latest Firefox Nightly 96.0a1 (2021-11-17) (64-Bit) on MacOS 10.15. The Cardholder Name is now captured and auto-filled as well.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.