build fails at TestXPC.cpp

CLOSED INVALID

Status

CLOSED INVALID
16 years ago
14 years ago

People

(Reporter: seandarcy, Assigned: netscape)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021003
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021003

building on rh8.0. ./configure gmake. Got this:

gmake[3]: Entering directory `/opt/mozilla/source/mozilla/js/src/xpconnect/tests'
TestXPC.cpp
c++ -o TestXPC.o -c -DOSTYPE=\"Linux2.5\" -DOSARCH=\"Linux\" -DOJI
-DJS_THREADSAFE -DJSFILE  -I../../../../dist/include/xpconnect -I../../.
./../dist/include/xpcom -I../../../../dist/include/string
-I../../../../dist/include/js -I../../../../dist/include/xpconnect_tests -I../../
../../dist/include/TestXPC -I../../../../dist/include
-I/opt/mozilla/source/mozilla/dist/include/nspr      -I/usr/X11R6/include  
-fPIC  -I
/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-pr
ivacy -pedantic -Wno-long-long -fshort-wchar -pthread -pipe  -DDEBUG -D_DEBUG
-DDEBUG_root -DTRACING -g -fno-inline  -I/usr/X11R6/include -
DMOZILLA_CLIENT -include ../../../../mozilla-config.h -Wp,-MD,.deps/TestXPC.pp
TestXPC.cpp
{standard input}: Assembler messages:
{standard input}:64404: Internal error, aborting at write.c line 796 in
adjust_reloc_syms
Please report this bug.
gmake[3]: *** [TestXPC.o] Error 1
gmake[3]: Leaving directory `/opt/mozilla/source/mozilla/js/src/xpconnect/tests'
gmake[2]: *** [libs] Error 2


Reproducible: Always

Steps to Reproduce:
1../configure
2.gmake
3.

Comment 1

16 years ago
> {standard input}: Assembler messages:
> {standard input}:64404: Internal error, aborting at write.c line 796 in
> adjust_reloc_syms
> Please report this bug.

your assumbler has aborted.  the bug you should file is with RedHat.
I have been building with RH80 without problems.
What Andrew said.  This bug should be filed against RedHat.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

16 years ago
Right you are. I was using binutils-2.13.90.0.2 which comes with rh 8.0
(surprised it works with your 8.0 ):

as --version
GNU assembler 2.13.90.0.2 20020802

Got binutils-2.13.90.0.4 from redhat rawhide. moz now builds.
Status: RESOLVED → CLOSED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.