Have a drop down list for 'Assigned To'

RESOLVED DUPLICATE of bug 52557

Status

()

Bugzilla
Creating/Changing Bugs
--
enhancement
RESOLVED DUPLICATE of bug 52557
16 years ago
6 years ago

People

(Reporter: Dru, Assigned: myk)

Tracking

Details

(Reporter)

Description

16 years ago
Some installations of bugzilla do not have lots of people
to whom the bugs are assigned to, and the default owner usually
just reassigns them to someone else. For these installations,
its a good idea to just have those fields become a drop down list.
I usually implement this at every site I go to.

Here is the code (I don't have a diff, sorry, I didn't use
CVS. It is really small, though.)

Thanks for giving this some time,

-------------
in CGI.pl, I changed GeneratePersonInput to:

sub GeneratePersonInput {
    my ($field, $required, $def_value, $extraJavaScript) = (@_);
    $extraJavaScript ||= "";
    if ($extraJavaScript ne "") {
        $extraJavaScript = "onChange=\"$extraJavaScript\"";
    }
#    return "<INPUT NAME=\"$field\" SIZE=32 $extraJavaScript 
VALUE=\"$def_value\">";


    SendSQL("select login_name from profiles order by login_name");
    my @line;
    my $uarray = [ [''] ];
    while (@line = FetchSQLData()) {
        push @$uarray, [ $line[0] ];
    }

    return BuildPulldown($field, $uarray , $def_value);
}

*** This bug has been marked as a duplicate of 52557 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.