Closed Bug 1741138 Opened 11 months ago Closed 5 months ago

"Continue" button does not work linkedin.com with ETP set to STRICT

Categories

(Core :: Privacy: Anti-Tracking, defect, P3)

Firefox 96
Other
Android
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox96 --- affected

People

(Reporter: raul.bucata, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Attached image Screenshot_4.png

"Environment:
Operating system: Android 11
Firefox version: Firefox Nightly 96.0a1 (2015845803 -🦎96.0a1-20211114093049🦎)

Preconditions:
ETP set to STRICT
Clean profile

Steps to reproduce:

  1. Navigate to :https://www.linkedin.com/learning-login/go/validate?account=73724860&redirect=https%3A%2F%2Fwww.linkedin.com%2Flearning-login%2Fcontinue%3FappToken%3Dbk1datz0e3H31DAda1pEdffMLlpqpPr_XgeSAoTts2M%26authUUID%3DMSkCcenhQN2SNEk59gt8Eg%253D%253D%26forceAccount%3Dfalse%26redirect%3Dlilearning%253A%252F%252Fwww%252Elinkedin%252Ecom%252Flearning%252Fllfe-callback&authUUID=MSkCcenhQN2SNEk59gt8Eg%3D%3D
  2. Accept the "Cookie" policy
  3. Enter invalid data into the input fields
  4. Tap on the "Continue" button
  5. Observe the result

Expected Behavior:
An error message should be displayed

Actual Behavior:
Nothing happens

Notes:

  • Not reproducible with ETP set to STANDARD
  • Works as expected using Chrome
  • Screenshot attached
  • Negative testing was performed due to a lack of valid data
Severity: -- → S3

This seems to be working fine for me, though I don't have to accept the cookie policy. So my guess is that it might be related to that. Paul, when you have a moment can you try to repro this?

Flags: needinfo?(pbz)

I do see the cookie policy banner. However, I cannot reproduce. The validation error shows up as expected.
Tested on Ubuntu 21.10, Nightly 96.0a1 (2021-11-22) (64-bit).

Flags: needinfo?(pbz)

Raul, is this still an issue? Paul and I were unable to reproduce the problem, and it's been months since then.

Flags: needinfo?(raul.bucata)

The issue is not reproducible on my side now using the latest build of Firefox Nightly. Using invalid credentials, the warning message is displayed, meaning that the "Continue" button works as expected.

Tested with:

Browser / Version: Firefox Nightly 102.0a1 (2015878251 -🦎102.0a1-20220502144301🦎)
Operating System: Samsung A51 (Android 11) -1080 × 2400 pixels 20:9 aspect ratio (~405 ppi density)
Operating System: Google Pixel 3 (Android 12) -1080 x 2160 pixels, 18:9 ratio (~443 ppi density)

Safe to say we can close this as WOKRSFORME.

Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(raul.bucata)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.