Cannot compile CVS mozilla after gnome 2.0.2 installation

VERIFIED INVALID

Status

SeaMonkey
Build Config
--
critical
VERIFIED INVALID
16 years ago
14 years ago

People

(Reporter: Stanislav Svarc, Assigned: hacker formerly known as seawood@netscape.com)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I installed recently Gnome 2.0.2, compiled it from source and after that I
noticed mozilla cannot be compiled issueing this error messgae

Error message:

gmake[4]: Entering directory `/home/axez/Downloads/CVS/Mozilla/mozilla/xpcom/base'
Creating .deps
../../config/nsinstall -R -m 644 nsAgg.h nsIAllocator.h nsCom.h nsComObsolete.h
nsCWeakReference.h nsIID.h nsISupportsObsolete.h nsTraceRefcnt.h nsWeakPtr.h
../../dist/include/xpcom
/usr/bin/perl -I../../config ../../config/build-list.pl
../../dist/include/xpcom/.headerlist nsAgg.h nsIAllocator.h nsCom.h
nsComObsolete.h nsCWeakReference.h nsIID.h nsISupportsObsolete.h nsTraceRefcnt.h
nsWeakPtr.h
../../config/nsinstall -R -m 644 nsError.h nsISupportsBase.h nscore.h nsID.h
../../dist/include/xpcom
/usr/bin/perl -I../../config ../../config/build-list.pl
../../dist/include/xpcom/.headerlist nsError.h nsISupportsBase.h nscore.h nsID.h
../../config/nsinstall -R -m 644 nsError.h nsISupportsBase.h nscore.h nsID.h
../../dist/sdk/xpcom/include
/usr/bin/perl -I../../config ../../config/build-list.pl
../../dist/include/xpcom/.headerlist nsError.h nsISupportsBase.h nscore.h nsID.h
Creating ../../dist/idl
../../config/nsinstall -R -m 644 nsIErrorService.idl nsIConsoleService.idl
nsIConsoleMessage.idl nsIConsoleListener.idl nsIException.idl
nsIExceptionService.idl ../../dist/idl
Creating _xpidlgen/.done
nsIErrorService.idl
../../dist/bin/xpidl -m header -w -I ../../dist/idl -I. -o
_xpidlgen/nsIErrorService nsIErrorService.idl
gmake[4]: *** [_xpidlgen/nsIErrorService.h] Segmentation fault
gmake[4]: *** Deleting file `_xpidlgen/nsIErrorService.h'
gmake[4]: Leaving directory `/home/axez/Downloads/CVS/Mozilla/mozilla/xpcom/base'
gmake[3]: *** [export] Error 2
gmake[3]: Leaving directory `/home/axez/Downloads/CVS/Mozilla/mozilla/xpcom'
gmake[2]: *** [tier_2] Error 2
gmake[2]: Leaving directory `/home/axez/Downloads/CVS/Mozilla/mozilla'
gmake[1]: *** [default] Error 2
gmake[1]: Leaving directory `/home/axez/Downloads/CVS/Mozilla/mozilla'
gmake: *** [build] Error 2
axez@terminator:~/Downloads/CVS/Mozilla/mozilla$


Gnome 2.0.2 components are as follows:

-rw-------    1 axez     users      328600 Aug 28 16:47 at-spi-1.0.2.tar.bz2
-rw-------    1 axez     users      245314 Aug 15 15:32 atk-1.0.3.tar.bz2
-r--r--r--    1 axez     users      262041 Jul 16 18:03 audiofile-0.2.3.tar.bz2
-rw-------    1 axez     users      566452 Jul 24 07:58
bonobo-activation-1.0.3.tar.gz
-r--r--r--    1 axez     users      400388 Jul 16 18:03 bug-buddy-2.2.0.tar.bz2
-rw-------    1 axez     users     1177465 Aug 21 14:49
control-center-2.0.1.1.tar.bz2
-rw-------    1 axez     users       78428 Jul 17 17:00 docbook-xml-4.2.zip
-rw-------    1 axez     users      892579 Oct  3 19:43 docbook-xsl-1.48.tgz
-rw-------    1 axez     users       67117 Oct  3 19:30 docbookx412.tgz
-rw-------    1 axez     users      433877 Sep 14 02:19 eel-2.0.7.tar.bz2
-rw-------    1 axez     users      360579 Aug 28 15:50 eog-1.0.3.tar.bz2
-rw-------    1 axez     users      297742 Aug 27 00:08 esound-0.2.29.tar.bz2
-rw-------    1 axez     users      306937 Jul 22 13:55 gail-0.17.tar.bz2
-rw-------    1 axez     users      227989 Aug 27 06:50 gconf-editor-0.3.1.tar.bz2
-rw-------    1 axez     users     1658780 Aug 30 18:33 gdm-2.4.0.11.tar.bz2
-rw-------    1 axez     users     1132910 Sep  5 08:33 gedit-2.0.5.tar.bz2
-rw-------    1 axez     users     1482363 Aug 15 15:32 glib-2.0.6.tar.bz2
-rw-------    1 axez     users     1766759 Sep 13 19:46 gnome-applets-2.0.3.tar.bz2
-r--r--r--    1 axez     users      155757 Jul 16 18:03 gnome-common-1.2.4.tar.bz2
-rw-------    1 axez     users     1092626 Sep  5 02:30 gnome-desktop-2.0.8.tar.bz2
-rw-------    1 axez     users     9184734 Aug 28 11:59 gnome-games-2.0.4.tar.bz2
-rw-------    1 axez     users      972900 Sep  4 11:32 gnome-media-2.0.2.5.tar.bz2
-rw-------    1 axez     users      983361 Aug 29 03:41
gnome-mime-data-2.0.1.tar.bz2
-rw-------    1 axez     users     1644072 Sep  5 23:30 gnome-panel-2.0.9.tar.bz2
-rw-------    1 axez     users      811896 Sep  5 02:30 gnome-session-2.0.7.tar.bz2
-rw-------    1 axez     users      398953 Aug 26 23:12
gnome-system-monitor-2.0.2.tar.bz2
-rw-------    1 axez     users      616470 Aug 15 15:32 gnome-terminal-2.0.1.tar.bz2
-rw-------    1 axez     users     1352538 Sep  4 22:04 gnome-utils-2.0.5.tar.bz2
-rw-------    1 axez     users      892634 Sep  4 23:41 gnome-vfs-2.0.4.tar.bz2
-rw-------    1 axez     users     2396821 Jul 22 06:58
gnome2-user-docs-2.0.0.tar.bz2
-rw-r--r--    1 axez     users     3888344 Oct  2 21:17
gnome2-user-docs-2.0.1.tar.bz2
-rw-------    1 axez     users     6118141 Aug 15 15:32 gtk+-2.0.6.tar.bz2
-r--r--r--    1 axez     users       99230 Jul 16 18:03 gtk-doc-0.9.tar.bz2
-r--r--r--    1 axez     users      396291 Jul 16 18:03 gtk-engines-1.9.0.tar.bz2
-r--r--r--    1 axez     users       88617 Jul 16 18:03 intltool-0.22.tar.bz2
-r--r--r--    1 axez     users      274885 Jul 16 18:03 libIDL-0.8.0.tar.bz2
-rw-------    1 axez     users      211553 Jul  1 08:33 libart_lgpl-2.3.10.tar.bz2
-r--r--r--    1 axez     users      470293 Jul 16 18:03 libbonobo-2.0.0.tar.bz2
-rw-------    1 axez     users      486241 Aug 30 14:53 libbonoboui-2.0.3.tar.bz2
-rw-------    1 axez     users      132964 Aug 28 16:07 libgail-gnome-1.0.1.tar.bz2
-rw-------    1 axez     users      264646 Aug 29 12:36 libglade-2.0.1.tar.bz2
-rw-------    1 axez     users      460569 Aug 31 07:52 libgnome-2.0.5.tar.bz2
-rw-------    1 axez     users      384320 Sep  4 19:53 libgnomecanvas-2.0.4.tar.bz2
-rw-------    1 axez     users      474178 Jul 28 20:01
libgnomeprint-1.116.0.tar.bz2
-rw-------    1 axez     users      282845 Jul 28 20:04
libgnomeprintui-1.116.0.tar.bz2
-rw-------    1 axez     users      965219 Sep  4 19:51 libgnomeui-2.0.5.tar.bz2
-rw-------    1 axez     users      337329 Aug 22 23:13 libgtkhtml-2.0.2.tar.bz2
-r--r--r--    1 axez     users      690581 Jul 16 18:03 libgtop-2.0.0.tar.bz2
-r--r--r--    1 axez     users      719124 Jul 16 18:03 librep-0.16.tar.bz2
-rw-------    1 axez     users      155093 Jul 23 03:00 librsvg-2.0.1.tar.bz2
-rw-------    1 axez     users      223187 Aug 25 18:43 libwnck-0.17.tar.bz2
-rw-------    1 axez     users     1562484 Aug 23 11:13 libxml2-2.4.24.tar.bz2
-rw-------    1 axez     users     1489697 Aug 23 11:53 libxslt-1.0.20.tar.bz2
-r--r--r--    1 axez     users      250649 Jul 16 18:03 libzvt-2.0.1.tar.bz2
-rw-------    1 axez     users      180773 Aug 23 15:59 linc-0.5.3.tar.bz2
-rw-------    1 axez     users     4978890 Sep 14 02:23 nautilus-2.0.7.tar.bz2
-rw-------    1 axez     users      553755 Jan 31  2002 orbit-python-1.99.0.tar.bz2
-rw-------    1 axez     users      769548 Aug 15 15:33 pango-1.0.4.tar.bz2
-r--r--r--    1 axez     users      484337 Jul 16 18:03 pkgconfig-0.12.0.tar.bz2
-rw-------    1 axez     users      131237 Jun 21 17:27 rep-gtk-0.16.tar.bz2
-rw-------    1 axez     users     1116879 Jun 21 18:08 sawfish-2.0.tar.bz2
-rw-------    1 axez     users      350919 Jul 25 08:09 scrollkeeper-0.3.11.tar.bz2
-rw-------    1 axez     users      460238 Sep  4 11:37 yelp-1.0.6.tar.bz2



I tried guessing that problem may be in LibIDL and tried downgrading version to
0.6.8 but still got the same error.
Interesting thing is tha compilation went just fine with Gnome 2.0.0
There's not enough information here to diagnose the problem.  You didn't say
what mozilla build options you were using or which compiler toolchain.
(Reporter)

Comment 2

16 years ago
Sorry, this is my first bugreport..:)


OS is Slackware 8.1 Linux with its standard gcc 2.95.3 compiler
I also have these CFLAGS defined in my /etc/profile
export CFLAGS='-O3 -funroll-loops -ffast-math -malign-double -mcpu=pentiumpro
-march=pentiumpro -fomit-frame-pointer -fno-exceptions'

Ok, here is my  .mozconfig

# sh
# Build configuration script
#
# See http://www.mozilla.org/build/unix.html for build instructions.
#

# Options for 'configure' (same as command-line options).
ac_add_options --prefix=/usr/lib/mozilla
ac_add_options --with-pthreads
ac_add_options --enable-toolkit-gtk
#ac_add_options --enable-xft
ac_add_options --enable-crypto
ac_add_options --disable-jsd
#ac_add_options --enable-calendar
ac_add_options --disable-bidi
ac_add_options  --disable-tests
ac_add_options --enable-svg
ac_add_options --disable-debug
ac_add_options --enable-optimize=-O3
ac_add_options --disable-dtd-debug
ac_add_options --enable-strip
ac_add_options --with-default-mozilla-five-home=/usr/lib/mozilla
ac_add_options --enable-elf-dynstr-gc
ac_add_options --enable-xterm-updates
ac_add_options --enable-cpp-rtti
ac_add_options --enable-cpp-exceptions
mk_add_options MOZ_INTERNAL_LIBART_LGPL=1
MOZ_INTERNAL_LIBART_LGPL=1
mk_add_options "march=i686 -mcpu=pentium"
ac_add_options --enable-extensions=default,irc
First thing, kill all of those extra compiler flags in CFLAGS.  We don't
regularly test with them so who know if they are causing a problem to occur. 
Second, please provide a configure log so that we can see exactly what the build
is detecting.   You are using the build option that builds mozilla against
gtk(1) but you have gtk2 installed on your system.  This should also affect what
version of libIDL is used to build xpidl, which appears to be what is segfaulting.  
(Reporter)

Comment 4

16 years ago
Ok, I have commented out those CFLAGS in /etc/profile and this time compilation
went past the point where it died with segfault before, so i think it fixed it.
I didnt manage to compile it though because it reported error somewhere near the
end of the build and it was totally unrelated ( something about mail`news )
After another update everything compiled fine, so i Think this is fixes
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Should have been resolved as Invalid since nothing changed in the Mozilla codebase.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID

Comment 7

16 years ago
v invalid.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.