reproducable 'GetQDGlobalsBlack' crash when opening new window and typing then hitting down quickly

RESOLVED DUPLICATE of bug 157157

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 157157
16 years ago
16 years ago

People

(Reporter: Daniel Bogan, Assigned: saari (gone))

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021008 Chimera/0.5+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.0.1) Gecko/20021008 Chimera/0.5+

with an existing window open, if i then open a second window, quickly type the
first few letters of a previously visted link, and then quickly hit the down
arrow  to pick from the list of previously visted links, we crash.

Reproducible: Always

Steps to Reproduce:
1. make new window.
2. type the first few letters of an existing link
3. hit the down key.

Actual Results:  
crash!

Expected Results:  
selecting a previously visited url from the list that pops up beneath the
location textfield.

Command:    Navigator
PID:        2982

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
 #0   0x91a7fb20 in GetQDGlobalsBlack
 #1   0x02acbca0 in 0x2acbca0
 #2   0x02b3b618 in 0x2b3b618
 #3   0x02b3af04 in 0x2b3af04
 #4   0x02aca4f4 in 0x2aca4f4
 #5   0x02b4c8ac in 0x2b4c8ac
 #6   0x02b2a5c8 in 0x2b2a5c8
 #7   0x02b3137c in 0x2b3137c
 #8   0x02b3abcc in 0x2b3abcc
 #9   0x02b5f74c in 0x2b5f74c
 #10  0x02ac03c0 in 0x2ac03c0
 #11  0x02abfa30 in 0x2abfa30
 #12  0x0063f99c in
ns4xPluginStreamListener::OnDataAvailable(nsIPluginStreamInfo*, nsIInputStream*,
unsigned)
 #13  0x00340704 in nsPluginStreamListenerPeer::OnDataAvailable(nsIRequest*,
nsISupports*, nsIInputStream*, unsigned, unsigned)
 #14  0x00453c40 in nsHttpChannel::OnDataAvailable(nsIRequest*, nsISupports*,
nsIInputStream*, unsigned, unsigned)
 #15  0x0016d3ac in nsOnDataAvailableEvent::HandleEvent()
 #16  0x05050450 in PL_HandleEvent
 #17  0x05050348 in PL_ProcessPendingEvents
 #18  0x050512f8 in nsEventQueueImpl::ProcessPendingEvents()
 #19  0x003d120c in -[EventQueueHandler eventTimer:]
 #20  0x907e521c in __NSFireTimer
 #21  0x90163888 in __CFRunLoopDoTimer
 #22  0x901493e0 in __CFRunLoopRun
 #23  0x9018157c in CFRunLoopRunSpecific
 #24  0x92ba34cc in RunCurrentEventLoopInMode
 #25  0x92bb32f4 in ReceiveNextEventCommon
 #26  0x92bda280 in BlockUntilNextEventMatchingListInMode
 #27  0x93082184 in _DPSNextEvent
 #28  0x930ccf84 in -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]
 #29  0x930ca500 in -[NSApplication run]
 #30  0x930d2598 in NSApplicationMain
 #31  0x00004b9c in _start (crt.c:267)
 #32  0x00004a1c in start

Thread 1:
 #0   0x90025e8c in select
 #1   0x0101c67c in poll
 #2   0x01018e50 in _pr_poll_with_poll
 #3   0x0017329c in nsSocketTransportService::Run()
 #4   0x05052ac4 in nsThread::Main(void*)
 #5   0x0101a2bc in _pt_root
 #6   0x90021428 in _pthread_body

Thread 2:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x010154f8 in PR_WaitCondVar
 #3   0x00142294 in nsDNSService::DequeuePendingQ()
 #4   0x00141cc0 in nsDNSService::Run()
 #5   0x05052ac4 in nsThread::Main(void*)
 #6   0x0101a2bc in _pt_root
 #7   0x90021428 in _pthread_body

Thread 3:
 #0   0x90042d68 in semaphore_timedwait_signal_trap
 #1   0x9003ef94 in _pthread_cond_wait
 #2   0x010152bc in pt_TimedWait
 #3   0x0101550c in PR_WaitCondVar
 #4   0x050563d8 in TimerThread::Run()
 #5   0x05052ac4 in nsThread::Main(void*)
 #6   0x0101a2bc in _pt_root
 #7   0x90021428 in _pthread_body

Thread 4:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x010154f8 in PR_WaitCondVar
 #3   0x05053bb0 in nsThreadPool::GetRequest(nsIThread*)
 #4   0x0505449c in nsThreadPoolRunnable::Run()
 #5   0x05052ac4 in nsThread::Main(void*)
 #6   0x0101a2bc in _pt_root
 #7   0x90021428 in _pthread_body

Thread 5:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90824180 in -[NSConditionLock lockWhenCondition:]
 #3   0x933515f4 in -[NSUIHeartBeat _heartBeatThread:]
 #4   0x9081cd38 in forkThreadForFunction
 #5   0x90021428 in _pthread_body

PPC Thread State:
  srr0: 0x91a7fb20 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x02acbca0  ctr: 0x91a7fae8   mq: 0x00000000
    r0: 0xffff0000   r1: 0xbfffe350   r2: 0x91a91f88   r3: 0x00000000
    r4: 0x00de21e4   r5: 0x00000020   r6: 0x00000000   r7: 0x91a7faf0
    r8: 0x0000ffff   r9: 0x0000ffff  r10: 0xffff0000  r11: 0xffffffff
   r12: 0xffffffff  r13: 0x00000000  r14: 0x00000000  r15: 0x00000001
   r16: 0x00000001  r17: 0x00000000  r18: 0x24002280  r19: 0x00000000
   r20: 0xbfffe840  r21: 0xbfffe7f0  r22: 0x027a17ec  r23: 0x00000000
   r24: 0x02921000  r25: 0x027ff108  r26: 0x0291a128  r27: 0x02921000
   r28: 0x000007a5  r29: 0x02818d44  r30: 0x02818d44  r31: 0x028193a0
A variant of bug 157157.

*** This bug has been marked as a duplicate of 157157 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.