Closed Bug 1742064 Opened 10 months ago Closed 10 months ago

Improve usage and performance of Activity Manager - for more transparency to end-users about Thunderbird processing

Categories

(Thunderbird :: General, enhancement)

Unspecified
All
enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: richard.leger, Unassigned)

References

(Blocks 1 open bug)

Details

In the framework of some Thunderbird troubleshooting it was observed that Activity Manager seems not always showing activity going on in TB, or does not perform well.
See one example among others of user story in https://bugzilla.mozilla.org/show_bug.cgi?id=1736526#c0 (see pdf attached).

Other time the blue wheel appears in the title bar indicating that TB is processing... but the Activity Manager may show no activity nor the status bar... making it hard to know what TB is doing... or what started process may take too long to complete... e.g loading a caldav calendar...

Improving usage of Activity Manager, for all features, would be a must to provide basic info to end-user when something is processing in TB (loading email, loading calendar, indexing, copying, moving, sending email, looking for folder, etc... or any action that would cause a blue wheel in the title bar).

Increasing processing transparency in TB would help to provide a hint what to look for when something goes wrong which is a great benefit of using open source software... you can always know what they do... to help report issues... and have it fixed...at some point :-)

Blocks: 1567764
See Also: → 1145753, 469050

Isn't this a duplicate of Bug 257942 ?

It's rather questionable if this is a "fixable problem". For the actual use case it's more of a question of looking at dev tools, logging and performance profiler. Ultimately, an end user does very little with the information that's there (except for perhaps that they can notice that gloda is a huge resource hog).

The use case was just an example... it is not explicitly to fix the global indexing issue.. it is about showing that Activity Manager is
useful as a starting point to identify an issue (easily accessible in the UI) to show what is processing in TB when an issue raise... console does not always indicate what is running or processing... for gathering logs you need to know what to look for... and profiling is great but very hard to read some found it useless other too complicated to read to find the culprit... Activity Manager should show more than just email indexing... and not be limited to just email feature... yes it is not for all users, yes it is limited in what it reports nevertheless that is the first place where advanced user (not IT expert) or TB troubleshooter newbies would look at to see: what's going on.

Maybe this bug could blog the [meta] bug?

To tag in with what Magnus wrote a) Activity Manager was never intended to be a debug tool or performance tool, and I suggest adapting it to that purpose probably isn't the best direction, b) if you put too much info in there, then it will be as overwhelming as Error Console.

That said, there is plenty of room for Activity Manger to improve https://mzl.la/3kTKS7x (just for starters)

yes it is not for all users

I disagree - the original intention is for it to be understandable and usable by all users.

Activity Manager should show more than just email indexing... and not be limited to just email feature

Given that email is the primary purpose, and something that users understand, it seems to me that this probably should be Activity Manager's focus.

As for gloda - it's probably too complex to be logging stuff there. And it was intentional that nothing more than "indexing" be displayed there. For gloda see https://wiki.mozilla.org/Thunderbird:Debugging_Gloda (linked from https://wiki.mozilla.org/MailNews:Logging )

Maybe this bug could blog the [meta] bug?

I don't understand what this means. But if the intention is "discussion" that should probably take place in tb-planning or some other venue.

OS: Unspecified → All

(In reply to Wayne Mery (:wsmwk) from comment #4)

yes it is not for all users
I disagree - the original intention is for it to be understandable and usable by all users.

What I meant is my mother or my MD would probably never look at the Activity Manager... but lambda or advance users who may be asked to help with TB issue (such as not responding) would look at the Activity Manager as a first step, just to see what is going on in TB... maybe it is the wrong approach but I am pretty sure most do that before going to console or gathering logs, debugger, perf profile, etc... even an advance troubleshooter in TB would look at the Activity Manager intuitively first supposedly...

Activity Manager should show more than just email indexing... and not be limited to just email feature

The same way I see Indexing email XXX of YYY I would like to see "Loading calendar XXX - Event YYY of ZZZ", "Compacting mailbox blabla@mydomain.com - Folder XYZ NN% progress", "Looking for folders in mailbox - blabla@mydomain.com - Found XYZ folders" (XYZ progressing as the task advance), etc...

Those are very simple status of TB processing... not meant to be full logging... we do have other stuff for that...

Activity Manager may have been originally design for email indexing but the name does not say Mail Activity Manager... meaning it can be used for any major feature of Thunderbird... Calendar/Contacts, etc... I would expect it to do so as an end-user... to show more transparently what TB is doing (main tasks and status progress)...

Given that email is the primary purpose, and something that users understand, it seems to me that this probably should be Activity Manager's focus.

Thunderbird was primarily and email client but currently is used to do much more than that so the tools shall adapted to new usage... Calendar/Contacts are also important feature used in Thunderbird among others...

Add-ons may also run some processing and should also be able/allowed to tap into the Activity Manager...

As for gloda - it's probably too complex to be logging stuff there. And it was intentional that nothing more than "indexing" be displayed there.

No need to do logging in the Activity Manager, but displaying the fact that Indexing is running on XX message out of YYY is currently useful to see that Thundebird is busy at something... if it suddenly slowdown because of indexing you kind of know why... The fact that I can see progress come, stop, freeze/not responding and go in Activity Manager already suggest there may be a problem with indexing feature or gloda and that is already a useful information to know for further troubleshooting...

My point here is how to improve transparency to end-user of what TB is doing/processing, get status/progress of major tasks in a friendly and simple UI, Activity Manager seems to be the best and natural contender for that...

A UI that's reasonable for the average user isn't going to have enough granularity to be useful.
For the troubleshooting cases, transparency if you will, you can enable logging but the amounts of data would be huge. We're not going to try to shoehorn the activity manager into something it was never designed to do.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.