Closed Bug 1742260 Opened 6 months ago Closed 4 months ago

Intermittent uriloader/exthandler/tests/mochitest/browser_download_spam_permissions.js | Cleanup function threw an exception - OperationError: Could not remove the non-empty directory at C:\Users\task_163744121014005\AppData\Local\Temp\1637444023082.

Categories

(Firefox :: File Handling, defect, P5)

defect

Tracking

()

RESOLVED FIXED
98 Branch
Tracking Status
firefox-esr91 --- unaffected
firefox94 --- unaffected
firefox95 --- unaffected
firefox96 --- wontfix
firefox97 --- fixed
firefox98 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: Gijs)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: nbeleuzu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=358722393&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/WxzIeSbHSZmYT494iaT0RA/runs/0/artifacts/public/logs/live_backing.log


[task 2021-11-20T21:33:44.082Z] 21:33:44     INFO - TEST-PASS | uriloader/exthandler/tests/mochitest/browser_download_spam_permissions.js | download is blocked - 
[task 2021-11-20T21:33:44.083Z] 21:33:44     INFO - Global property added while loading chrome://browser/content/nsContextMenu.js: screenshotsDisabled
[task 2021-11-20T21:33:44.083Z] 21:33:44     INFO - Global property added while loading chrome://browser/content/nsContextMenu.js: SCREENSHOT_BROWSER_COMPONENT
[task 2021-11-20T21:33:44.084Z] 21:33:44     INFO - Leaving test bound check_download_spam_permissions
[task 2021-11-20T21:33:44.084Z] 21:33:44     INFO - Buffered messages finished
[task 2021-11-20T21:33:44.085Z] 21:33:44     INFO - TEST-UNEXPECTED-FAIL | uriloader/exthandler/tests/mochitest/browser_download_spam_permissions.js | Cleanup function threw an exception - OperationError: Could not remove the non-empty directory at C:\Users\task_163744121014005\AppData\Local\Temp\1637444023082.
[task 2021-11-20T21:33:44.085Z] 21:33:44     INFO - Specify the `recursive: true` option to mitigate this error
[task 2021-11-20T21:33:44.086Z] 21:33:44     INFO - GECKO(3392) | console.log: Downloads: Closing the downloads panel.
[task 2021-11-20T21:33:44.086Z] 21:33:44     INFO - GECKO(3392) | console.log: Downloads: Downloads panel has hidden.
[task 2021-11-20T21:33:44.086Z] 21:33:44     INFO - GECKO(3392) | console.log: Downloads: Downloads panel is now closed.
[task 2021-11-20T21:33:44.087Z] 21:33:44     INFO - GECKO(3392) | console.log: Downloads: A download data item was removed.
[task 2021-11-20T21:33:44.087Z] 21:33:44     INFO - GECKO(3392) | console.log: Downloads: Removing a DownloadsViewItem from the downloads list.
[task 2021-11-20T21:33:44.088Z] 21:33:44     INFO - GECKO(3392) | console.log: Downloads: The downloads item count has changed - we are tracking 0 downloads in total.
[task 2021-11-20T21:33:44.088Z] 21:33:44     INFO - GECKO(3392) | console.log: Downloads: Removing the panel's hasdownloads attribute.
[task 2021-11-20T21:33:44.089Z] 21:33:44     INFO - GECKO(3392) | [Child 1964, Main Thread] WARNING: NS_ENSURE_TRUE(mDoneSetup) failed: file /builds/worker/checkouts/gecko/editor/composer/nsEditingSession.cpp:1175
[task 2021-11-20T21:33:44.089Z] 21:33:44     INFO - GECKO(3392) | MEMORY STAT | vsize 2104368MB | vsizeMaxContiguous 66943585MB | residentFast 388MB | heapAllocated 161MB
Has Regression Range: --- → yes

I suspect what is happening here is we try to remove the downloads dir without first waiting for downloads to have completely finished (such that the background-thread writes to the downloads dir have stopped), so when we try to remove the directory on Windows, it tries to remove all the files there, but after removing some files they get re-created by the still-being-written downloads.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(enndeakin)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9ba89a5d6d12
have 'save link' in download spam protection test finish downloading before we finish the test to fix intermittent failures, r=mhowell
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 98 Branch

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

You need to log in before you can comment on or make changes to this bug.