All users were logged out of Bugzilla on October 13th, 2018

spacer checker in nsImageGTK running off end of images

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: tor, Assigned: tor)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
Accidentally used the left,right coordinates when checking the middle
alpha channel bytes of a 1-bit alpha image.  Slows things down, probably
misidentified some large spacers, and could cause a crash if you're
unlucky.
(Assignee)

Comment 1

16 years ago
Created attachment 102738 [details] [diff] [review]
fix spacer detection loop control

Comment 2

16 years ago
*** Bug 164381 has been marked as a duplicate of this bug. ***
Comment on attachment 102738 [details] [diff] [review]
fix spacer detection loop control

r=biesi
Attachment #102738 - Flags: review+
Comment on attachment 102738 [details] [diff] [review]
fix spacer detection loop control

sr=blizzard
Attachment #102738 - Flags: superreview+
Comment on attachment 102738 [details] [diff] [review]
fix spacer detection loop control

a=dbaron for trunk checkin
Attachment #102738 - Flags: approval+
(Assignee)

Comment 6

16 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 7

16 years ago
*** Bug 175082 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.