Status

()

P3
major
VERIFIED FIXED
19 years ago
19 years ago

People

(Reporter: gregj, Assigned: gagan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
here is what is left on the console:

nsLayoutHistoryState::AddState OOPS!. There was already a state in the hash
table for the key

I am using the 1999102708 nightly build.
I rm -rf .mozilla and it gave me the same result. I havent tried on mac or
windows yet.. I can try at work tommorrow if you need.

Also. if I go directly to the url instead via the w3.org index page link. I dont
get the nsLayoutHistState::AddState... error message, it just crashes the
browsers.
(Reporter)

Comment 1

19 years ago
It crashes on windows 95 also.

Updated

19 years ago
Assignee: troy → warren

Comment 2

19 years ago
Warren, you seem to have been in there most recently (so has pnunn and rpotts).
Here's the stack trace:

ImageConsumer::OnStartRequest(ImageConsumer * const 0x01cd0298, nsIChannel *
0x01cd46d0, nsISupports * 0x00000000) line 168 + 14 bytes
nsChannelListener::OnStartRequest(nsChannelListener * const 0x01cd0310,
nsIChannel * 0x01cd46d0, nsISupports * 0x00000000) line 1349 + 43 bytes
nsChannelListener::OnStartRequest(nsChannelListener * const 0x00e529c8,
nsIChannel * 0x01cd46d0, nsISupports * 0x00000000) line 1349 + 43 bytes
nsChannelListener::OnStartRequest(nsChannelListener * const 0x01cd29a0,
nsIChannel * 0x01cd46d0, nsISupports * 0x00000000) line 1349 + 43 bytes
nsHTTPResponseListener::FinishedResponseHeaders() line 603 + 37 bytes
nsHTTPResponseListener::OnDataAvailable(nsHTTPResponseListener * const
0x01c1e630, nsIChannel * 0x01cd10e0, nsISupports * 0x01cd46d0, nsIInputStream *
0x01cf9da0, unsigned int 0, unsigned int 888) line 151 + 8 bytes
nsOnDataAvailableEvent::HandleEvent(nsOnDataAvailableEvent * const 0x01cdda30)
line 413
nsStreamListenerEvent::HandlePLEvent(PLEvent * 0x01cfb360) line 169 + 12 bytes
PL_HandleEvent(PLEvent * 0x01cfb360) line 537 + 10 bytes
PL_ProcessPendingEvents(PLEventQueue * 0x00c1acc0) line 498 + 9 bytes
_md_EventReceiverProc(HWND__ * 0x000f03cc, unsigned int 49425, unsigned int 0,
long 12692672) line 972 + 9 bytes
USER32! 77e135f8()
USER32! 77e13769()
USER32! 77e17b9a()
main(int 1, char * * 0x00a82fa8) line 135 + 11 bytes
mainCRTStartup() line 338 + 17 bytes
KERNEL32! 77e9bc52()

Updated

19 years ago
Assignee: warren → gagan

Comment 3

19 years ago
Gagan, is this the crash you were mentioning -- because the notification came
prematurely that the image was done, and imagelib tore down it's image data?
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

19 years ago
this looks like a different bug.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
Hmm... I can't seem to reproduce it maybe this was being caused by the same bug
as the 17393. I would mark this as fixed for now. Reopen ifyou still see the
problem.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
This crash is not occuring in the Oct 12th Linux build either. Marking as
verified fixed.
You need to log in before you can comment on or make changes to this bug.