Back button does not behave properly

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: Bill Onesty, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I recently upgraded from MOZ 1.0.1 to 1.1 and since then I notice the back
button does not behave properly. If I go to a page with frames, and click on a
link in one frame that changes the contents of another frame and then click the
back button, I expect only the most recently changed frame to revert to its
previous contents. Instead, the entire page goes back to whatever the page was
before coming to the framed page. I hoped that using the right click menu in the
frame itself and using back from that menu would do what I wanted. Instead, it
did exactly what the main back button does.
Does this happen on all framed pages?  Or only some?
Assignee: asa → radha
Component: Browser-General → History: Session
QA Contact: asa → claudius

Comment 2

15 years ago
I think this is a duplicate of 171165.
Please provide a url or testcase. 

Comment 4

14 years ago
This problem is repeatable and not existant in Mozilla or Firebird.

Comment 5

14 years ago
This happens in Firebox .8.

Comment 6

14 years ago
Jessica or Bill, can you please provide a URL to test this? Thanks.

Comment 7

14 years ago
Worksforme.  The back and forward buttons load the correct pages for me, in
Mozilla (20040622 nightly), Firefox 0.9, and IE 6.  See my test
http://www.milamberart.com/bugzilla/moz-frames.html

Suggest bug is invalid without additional information.

Comment 8

13 years ago
> Worksforme.  The back and forward buttons load the correct pages for me, in
> Mozilla (20040622 nightly), Firefox 0.9, and IE 6.  See my test
> http://www.milamberart.com/bugzilla/moz-frames.html

> Suggest bug is invalid without additional information.

I think I've noticed this behavior occasionally although the Back button
usually works okay with frames.  (It sounds like it depends on...well...
I wouldn't know what to guess.)



Comment 9

12 years ago
(In reply to comment #6)
> Jessica or Bill, can you please provide a URL to test this? Thanks.

I noticed this bug at www.f-1.ru. During navigation on that site "back" returns
me outside of f-1.ru, however, it is expected just previous page on the current
site (f-1). I use firefox 1.0.6. With IE it works OK.

Comment 10

12 years ago
 I was able to replicate this problem once while running the daily build on SuSe 10.0. After that one time, I was not able to replicate this problem on SuSe. 

I was not able to replicate this problem using the daily build on Windows XP. I was not able to replicate this problem running the daily build on Mac OS 10.3.

Comment 11

12 years ago
WFM on www.f-1.ru (Firefox 1.5.0.3, windows XP SP2)
I think the bug is pretty old (2002-10-13) ... and was reported for Mozilla suite 1.1 ...

Since 2002, the platform for FF 1.5 and SeaMonkey is Mozilla 1.8.0.x ... and back button behaviour has been rewrited ("blazingly fast Back and Forward feature" see bug 274784).
So, i think this bug must be closed (except if a valid test case for a particular version is entered)

Comment 12

10 years ago
I tested this at www.f-1.ru , which is mentioned in Comment#9.  The back button worked well on all of the links.  The frames behaved as expected. 

This WORKSFORME.

Comment 13

10 years ago
(In reply to comment #12)
> I tested this at www.f-1.ru , which is mentioned in Comment#9.  The back button
> worked well on all of the links.  The frames behaved as expected. 
> 
> This WORKSFORME.
> 
I forgot to add that I am testing this with Windows XP on a Dell system with a P4 processor and 3 GB of RAM.

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
marking wfm based on the above comments
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.