Virtualcobalts.com site form doesn't update amount to be billed (price)

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
4 years ago

People

(Reporter: d_yerrick, Unassigned)

Tracking

Details

(Whiteboard: [bug248549notfixed], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

When I choose a site type at https://www.virtualcobalts.net/siteform.asp ,
the web form does not update the price.

Reproducible: Always

Steps to Reproduce:
1. Make sure PSM works.
2. https://www.virtualcobalts.net/siteform.asp
3. Observe that the read-only textbox next to "Amount to be billed"
   contains $0.00
4. Click "Starter Site 12 month term@ $2.95 per month."

Actual Results:  
"Amount to be billed" value remains $0.00

Expected Results:  
"Amount to be billed" value changes to $35.40

The form works properly in IE 5.5 SP2 on Windows 2000.

"Browser::DOM HTML" is a wild guess.  As with other reports of differences
between Mozilla and IE script behavior, feel free to morph this bug to
Tech Evangelism::Canada if it turns out that VirtualCobalts.com is using
IE-specific scripting.

Comment 1

16 years ago
javascript console says:
Error: frmValidate is not defined
Source File: https://www.virtualcobalts.net/siteform.asp
Line: 338

338: var xtm = frmValidate.term.value;

the page has a form named frmValidate, but that does not give it permission to
reference it like that.

==> Evang
Assignee: jst → momoi
Status: UNCONFIRMED → NEW
Component: DOM HTML → English: Non-US
Ever confirmed: true
OS: Windows 2000 → All
Product: Browser → Tech Evangelism
QA Contact: stummala → jeesun
Hardware: PC → All
Version: other → unspecified

Comment 2

16 years ago
Mass reassigning English-Other bugs to general default assignees.
Assignee: momoi → english-other
QA Contact: jeesun → english-other
(Reporter)

Comment 3

15 years ago
This happens with the renewal form as well.

Updated

14 years ago
Whiteboard: [bug248549notfixed]
404
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20100101 Firefox/23.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.