[DOGFOOD] Back button memory lossage.

VERIFIED DUPLICATE of bug 18038

Status

P3
normal
VERIFIED DUPLICATE of bug 18038
19 years ago
14 years ago

People

(Reporter: astrosmash, Assigned: radha)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
It appears that the Mozilla back button will 'forget' about the previous
document, if the previous document was not fully loaded.

Steps to reproduce:

- Start Mozilla @ http://www.mozilla.org

- Load a larger-than-normal page, such as http://www.snippets.org

- Before the document has finished loading, click one of it's links, such as
"What is SNIPPETS" (http://www.snippets.org/SNIPPETS.TXT)

- Read all about Snippets, then click the Browser's back button.

Expected behavior:
You are returned to www.snippets.org

Actual behavior:
You are returned to mozilla.org

---

Try this again, however, wait for www.snippets.org to completely load before
clicking "What are SNIPPETS"

Back button works as expected.

---

This has been very reproducible on my machine now that incremental reflow has
been implemented.

Machine : P2 266
OS      : WinNT SP4
Build   : 1999102608
(Reporter)

Comment 1

19 years ago
*** Bug 16704 has been marked as a duplicate of this bug. ***
This is because, when a page doesn't load completely or successfully, it is
taken out of the session history, so that when you go back thro' history you
won't cross the unvisited/unsuccessfully loaded page. Clicking on a URL
while the current page is loading, results in a error code from necko indicating
unsuccessful *completion* of load, and SessionHistory will take it out of its
stack. See bug # 5905.

Updated

19 years ago
QA Contact: leger → paulmac

Comment 3

19 years ago
paulmac...isn't this a dup of a known problem.

Updated

19 years ago
Assignee: leger → radha
QA Contact: paulmac → claudius

Comment 4

19 years ago
Radha, I still think that if a page *starts* to load, it should be entered into
SH. This is how 4.x works. Why are we changing the behavior?
Status: NEW → ASSIGNED
Target Milestone: M12
Right now, based on the current necko notifications there is no way for me to
tell the difference between,

"A page started to load and didn't finish it" and "The page didn' even start to
load". I have to speak to the necko people and figure that out. When that
happens, I s'd be able to accomodate this feature.

Comment 6

19 years ago
I added this to the release notes, that some visited urls may appear to have
been 'forgotten'.

Comment 7

19 years ago
*** Bug 17933 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
Summary: Back button memory lossage. → [DOGFOOD] Back button memory lossage.
Whiteboard: [PDT+]

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 8

19 years ago
If this is a duplicate of 16704, then this bug is logically a duplicate of
16782. Marking as such and verifying.

*** This bug has been marked as a duplicate of 16782 ***
Status: VERIFIED → REOPENED
18038 addresses this problem too.

*** This bug has been marked as a duplicate of 18038 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 10

19 years ago
[bugday] verifiying dupe. history problems.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.