Closed Bug 1743133 Opened 6 months ago Closed 18 days ago

7.86 - 7.59% Heap Unclassified / Heap Unclassified (OSX) regression when Firefox is built with the macOS 11 SDK

Categories

(Core :: Widget: Cocoa, defect, P2)

defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr91 --- unaffected
firefox94 --- unaffected
firefox95 --- unaffected
firefox96 --- disabled

People

(Reporter: andrej, Unassigned)

References

Details

(Keywords: perf, perf-alert, Whiteboard: [mac:integration] )

Perfherder has detected a awsy performance regression from push 572b175efb0960eb15cc814d9c8f8f65afecae52. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
8% Heap Unclassified macosx1015-64-shippable-qr tp6 125,319,213.79 -> 135,166,190.05
8% Heap Unclassified macosx1015-64-shippable-qr tp6 126,854,827.82 -> 136,487,417.50

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(mh+mozilla)
Flags: needinfo?(mh+mozilla) → needinfo?(haftandilian)

Set release status flags based on info from the regressing bug 1696504

== Change summary for alert #32530 (as of Sun, 28 Nov 2021 06:09:40 GMT) ==

Regressions:

Ratio Test Platform Options Absolute values (old vs new)
4% amazon PerceptualSpeedIndex macosx1015-64-shippable-qr cold fission webrender 518.62 -> 541.00
4% amazon ContentfulSpeedIndex macosx1015-64-shippable-qr cold fission webrender 518.21 -> 540.25

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=32530

Blocks: 1696504
Flags: needinfo?(haftandilian)
Summary: 7.86 - 7.59% Heap Unclassified / Heap Unclassified (OSX) regression on Wed November 24 2021 → 7.86 - 7.59% Heap Unclassified / Heap Unclassified (OSX) regression when Firefox is built with the macOS 11 SDK
Keywords: regression
No longer regressed by: 1696504
Priority: -- → P2
Whiteboard: [mac:integration]

This is likely due to different font memory management done by macOS system libraries. We probably can't do much about it.

Status: NEW → RESOLVED
Closed: 18 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.