"publish as" fails with ftp 553 error

VERIFIED WONTFIX

Status

()

Core
Networking: FTP
VERIFIED WONTFIX
16 years ago
16 years ago

People

(Reporter: Krist van Besien, Assigned: Brade)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020902
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020902

When I want to publish a page to my server I get the following error message:
553: data/web/docs/moredocs/index.html : a file or directory in the path does
not exist
It apears this error is caused by composer trying to ftp
data/web/docs/moredocs/index.html 
to the server in stead of 
/data/web/docs/moredocs/index.html


Reproducible: Always

Steps to Reproduce:
1.after editing a file click "publish as"
2.Settings are:
  publishing addres - ftp://ftp.somesite.com/data/web/docs
  subdir - /moredocs
  filename - index.html

Actual Results:  
an error message is produced.

Expected Results:  
ftp the file...

The problem dissapeared when the publishing addres was changed from:
ftp://ftp.somesite.com/data/web/docs
to
ftp://ftp.somesite.com//data/web/docs

It apears that in this case mozilla retains the first slash in the path, and
correctly uploads the file.
The doubling of the slash after the hostname is counterintuitive, and probably
not in accordance with URL syntax.
==> Kathy
Assignee: syd → brade
(Assignee)

Comment 2

16 years ago
actually it has to do with the login
when you login to an ftp server, you may be put into a subdirectory (or not)
It sounds like in your case, you are put somewhere not at the root.
If your login area happens to have a directory named "data" which has in it a
directory named "web" (etc.) then the files would correctly publish in that
location.

When you want to get to the root of an ftp server, you need to add the extra
slash.  I don't know of any other workaround.  The extra slash tells the ftp
server to go to the root rather than relative.

The browser also works this way, if you enter an ftp url.

I hope I've explained the above clearly.  Feel free to comment here to get
clarification.

-->wontfix since it makes sense that the login go to the local location that you
login to and not to the root area
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Component: Editor: Composer → Networking: FTP
OS: Linux → All
Hardware: PC → All
Resolution: --- → WONTFIX

Comment 3

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.